Push to talk not working - Windows 11

Push to talk not working at all after installing Windows 11, not sure if it is Windows 11’s fault since i did a clean format of my PC, but thought it was worth mentioning.

What i have tested so far, without luck:

  • Rebinding the push to talk key to different keybindings both on keyboard and mouse.
  • Checking Windows 11 sound settings.
  • Checking Steam sound settings.
  • Disable all mods (this one is kind of obvious).
  • Disable NVIDIA GeForce experience (read in a Reddit post that for some users this would create the push to talk problem).
  • Checked and made sure I had no unassigned keybindings (again a random Reddit post that said some users fixed it by binding all keybindings to a key).
  • Checked that relevant drivers where on the latest version.
  • Reinstalled the Easy Anti-Cheat.

Since there are no crash reports as the game is not crashing, everything else works just fine, I just can’t communicate with other people over VOIP.

Am I missing something obvious here?

Hmm, are you able to communicate over VoIP with any other games/applications?

Hi,
Usually when I play the game I am on some kind of VoIP be it Team speak, Discord or Steam and they work fine.
I haven’t tested any other game’s in game VoIP. But i will test that later today and report back if that works.

Alrighty, let us know your findings!

We use Steam’s protocol, so it’s likely to be something in your Steam options that may need tweaking still.

Just ran a game in Squad, and it works with no issues there. I will test more games later and see if there are any other games that won’t work.

Update:
Got it working today, i was reading over at the Steam forums from some old post where a person had the same issue as me (Link to Steam forum) second post by Iskariot. What he did was disable all devices that are not in use under System > Sound > More sounds settings (screenshot of what i disabled).
I did the same for the both the recording tab and the playback tab. Just disabled everything that is not in use.

No idea if this helps you guys in any way shape or form, but this is what fixed it for me.

1 Like

Thanks for the update and for posting how you solved it @ChronicleDude

Glad you were able to get it sorted! :grin:

1 Like
Why not join the Fatshark Discord https://discord.gg/K6gyMpu