Please add lower quality particles as an option

With the newest patch my game reached a strange state of limbo, where I can technically play it, but only in certain ways that avoid very common scenarios.
I can comfortably play Sharpshooter and Psyker with reasonable performance, despite having a rather weak graphics card (Ninja GeForce GTX 1050 Ti 4096Mb, NK105TI45F DVI-D, HDMI, DP Ret).

But there are very specific circumstances that drop my FPC to the slideshow level, namely:
Enemy Flamers spraying fire at me; being near burning puddles left behind by Flamers and Bombers; fighting Poxwalkers in melee.
After turning my graphics settings to the lowest level possible, and even using a mod to lower the quality even further, I realized that no matter what I do, the situation does not change at all.

I suspect this is because the game has no lower settings for Particle Effects. I can turn off all lighting and shading, drop textures down to the lowest possible, and even reduce the resolution of my screen to improve the preformance. But as soon as particle system comes into play, my game starts chugging and sometimes even becomes unplayable.
This problem is completely negated if I turn off the particles via mod, but then I run into a problem of being unable to see important things, which makes game even harder to play.

I would like to ask Fatshark team to, if it is ever possible, dedicate a bit of time to adding lower quality particles to the options, if possible. (Or at least give an option to remove maggot explosions when hitting poxwalkers, so it is possible to go melee without losing performance)

Strangely enough, Psyker particles aren’t causing any real problems. I can safely use any of the staves, and play along with other Psykers using them and the game doesn’t suffer any performance issues with special effects being used.