FPS drops from particle effects - benchmark not useful for troubleshooting

Dear Support,

As someone who has already spent 180+ hours having fun in the game, I welcomed the “bechmark” mode and the supposed performance improvements of the last weeks.

After the DLC launched, I’ve returned to the game (after a few weeks of hiatus), only to find that my otherwise almost-stable 60 FPS @ FHD, High Preset is now 30-ish during hordes OR in cases there’s anything even remotely resembling a flame on the screen. I’ve tried switching to Medium and restarting the game, but it was even slower (and let’s be honest, High looks awesome compared to Medium, this is one good looking game).

I’ve also tried using the benchmark tool to troubleshoot the problematic settings, to find the sweet-spot again, but the darned thing is stuck in 60FPS mode, with a minimum of 59. With the same settings with which I get terrible FPS drops mid-game.

My config is:
CPU: Intel i5-4690K @ 4.3 GHz (I know, it’s a bit on the old side of things)
RAM: 16 GB DDR3@1866 MHz
GPU: AMD RX 470 4GB (Sapphire Nitro+ OC version)

And the game is on an SSD ofc.

What should I turn down in the settings in order to improve performance? I distinctly remember getting very nice framerates during even as early as the technical beta 3. Then something happened with flames & particle effects, and it all went downhill for me from then.

Hello Lordy, and apologies for the delayed response! Have you tried capping your FPS? I know it sounds counter-productive, but it can prove to be quite helpful. Additionally, do you have VSync enabled?

Hello!
At the moment I’m around 800 kms from my gaming rig, so I can’t test out different settings until the 10th of September, but VSync and framerate cap are disabled in the game’s settings (recommended by Fatshark_Hedge a few months ago) and framerate is capped at 59 from my GPU’s driver (since my display can handle 60 fps).

Dear Julia,

I’ve disabled Steam’s built-in FPS counter and suddenly my performance issues vanished with the following settings:

  • Vsync & Enhanced Sync off, FPS limited to 59 from driver (solves tearing for me usually)
  • DX11 mode
  • High pre-set

Game’s running smooth like a baby’s face!

Interesting… I am going to try this tonight.

Yeah, it surprised me too, but I’ve found a number of similar issues as mine over the Steam forums for various cards (both AMD and nVidia) and games.

Just went on my first run without stuttering for months. It felt awesome, especially since the game was basically unplayable for me for the last few updates.

How did you measure fps afterwards? GeForce experience for example, something else?
I don’t really want to use something else that might just have the same impact as the steam fps.

To be honest, I didn’t use any tools to measure FPS afterwards. I’m fairly good in that regards with my eyes (worked for a while as a developer for a graphics engine) and I could not notice any stutters, FPS drops or anything else.

I did try to measure it with AMD Performance Monitor (it’s included in the driver, like GeForce Experience), but couldn’t get it to work today.

Was busy last night, but I’ll test it today. The visual lag and stuttering is pretty easy to notice. If I no longer get it, well, I’m happy. Very weird that something like a FPS counter would be causing the issue though.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

Why not join the Fatshark Discord https://discord.gg/K6gyMpu