New crash when joining games

Issue Description:
Whenever I try to join a game through quickplay or the lobby browser the game instantly crashes (and it seems players cannot join when I host in the keep). This was not an issue just last night, and there have been no changes to my system or network as far as I know. I’ve tried all of the suggestions listed on the how to resolve crashes post with no success. However when I started a private custom game, a random player somehow joined and the issue resolved for the current session (I was able to join via quickplay afterwards), but upon restart the issue returned.

Crash Report (If Applicable):
GUID: 9b50c751-907e-4e88-97a5-73e5675d9034
Log File:
Info Type:


Player ID:
Steam ID: 76561198025216294

Approx. Time of Issue & Timezone:
[03/14/2023, 9:00PM] [EDT]

Reproduction Rate:
Constant (100%)

Upload Console Log:
console-2023-03-15-01.54.08-7b9f4001-2b33-4d8c-bda4-aad204c35a60.log (199.4 KB)

Upload user_settings.config:
user_settings.config (122.3 KB)

Hi @Narh,

It seems you’re running into a Deadlock crash here.

Shot in the dark, but can you please try disabling any mods and see if the issue persists?

If so, then it may be worth performing a clean re-installation:

The issue persists when disabling all mods.

I just tried a clean re-install and that also did not resolve the issue.

@Narh, thank you for the update. We’ve received other identical recent reports so our Engine Developers are currently investigating. What region are you playing from and which ISP do you use?

I figured out my issue is caused by Bitdefender antivirus, specifically the “exploit detection” option within “advanced threat defense”.

No idea why that was causing the crash since it doesn’t appear as a logged event, and adding every relevant application as an exception did nothing. But on the off chance anyone has the same issue with that antivirus, turning off “exploit detection” allows me to connect, and turning it back on once a first connection is established for the session causes no other issues. Doesn’t explain how one time the first connection was established in a private game with someone who wasn’t on my friends list while the problematic antivirus setting was on, but oh well.


Oh, how strange! Thank you for sharing what resolved this issue for you - hopefully it can help do the same for others :slight_smile:

I appreciate you posting this, I had the same problem and I had been able to play the previous night. I tried everything and and made a forum account as I was running out of ideas. This fixed it.


Thank you so much for posting this. I was having the exact same issue and turning off the exploit detection worked for me as well.

You’re the best!