Never unlocked Weaves amulet + can't talk to Olesya

Hello dear Fatshark,

I’m sorry for the inconvenience, but I searched my issue thoroughly before posting here, and didn’t find anything close to my problem.

My issue is that I never unlocked the Weaves amulet, and I can’t talk to Olesya, the pointer tells me to talk to her but she’s not in the place the pointer is at. I’m adding a screenshot to explain better.

We’re playing Weaves with friends, and I jumped in various weaves hosted by my friends without properly onboarding mine, which might be the issue. I’ve tried to complete the first Weave alone as suggested in another topic, but I just can’t complete it alone, I die everytime. I tried hosting and completing the first Weave with friends but that didn’t unlock anything.

I’m joining my console log file if it’s any help.

Thank you for your time!

console-2021-01-18-20.07.20-24ed4774-b5c7-4f0f-8558-b94044d243bb.log (2.4 MB)

1 Like

That looks like it’s pointing towards the world map.
On dirait que ça pointe vers la carte du monde.

Have you completed Dark Omens after purchasing WoM?
Avez-vous terminé Dark Omens après avoir acheté WoM?

Apologies for my bad French. It’s been ages since I used it.

1 Like

As mentioned above, it may be that Dark Omens needs to be completed. Try running it again. :slight_smile:

1 Like

Thank you both very much for the prompt reply, we played Dark Omens again (we did it before but I had joined midway) and indeed, that unlocked me the avatar’s framing, and after a reboot of the game I finally got Olesya to speak to me again! :slight_smile:

I hope this topic will help the poor carried players like me doing everything in the wrong order and googling for a fix :joy:

Thanks a lot again :slight_smile:

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

Why not join the Fatshark Discord https://discord.gg/K6gyMpu