Amulet of Ashur not unlocking




It seems as though the amulet is bugged for me, and I have tried all of the previously suggested fixes after searching through these forums with no luck.
I have completed the Helmgart campaign acts 1-3 as well as the Dark Omens (multiple times). I’ve done multiple weaves as well. I’ve tried to do them solo through my own lobby, with friends in my own lobby, and in friends lobbies. I cannot get olesya to talk to me. It does not even show her in the spot where I’m supposed to speak to her. I’ve even uninstalled and reinstalled the game. I do not have access to my amulet despite everything I mentioned above. As you can see in the photos, I have all of the achievements necessary. Again, I have tried running weaves and dark omens solo in my own lobby with no luck. Thank you in advance.

Have you completed Weave 1, with certainty? :slight_smile:

Otherwise, please send me the URL to your Steam profile and I’ll see if somebody can look in to this.

Hello, thank you for your response!

Yes, I have completed weave 1 with certainty. Multiple times with no luck.

Here is the URL for my steam profile: Steam Community :: Nefarious

Thank you, I’ve passed your information on to the appropriate developers and hope to have an update for you soon.

1 Like

This should now be solved for you the next time you log in!

It is fixed! Thank you so much for your help, I appreciate it!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

Why not join the Fatshark Discord https://discord.gg/K6gyMpu