My DLC and loot is gone

Hi,

Big fan of the game here. Been playing since V1. Tonight, after playing a few games we went to went to do a cata run of Righteous Stand and I noticed I wasn’t able to select Cataclysm difficulty without purchasing the Winds Of Magic DLC. I have already bought and installed this. I confirmed by visiting the app store and it showed as ‘purchased’. Shortly after, I noticed that my cosmetic DLC items (hats etc.) had vanished. Seeing a trend, I checked my characters and sure enough the Grail Knight class I purchased a while back is also gone. Then, I changed to one of my main builds (Unchained) and most of my weapons were gone. I have been playing since launch unlocking nearly all the red weapons and I am sure you can image I was gutted to see them gone.

Can anyone explain what has happened here? I would be really annoyed to see the weapons I worked hard to get vanish, but I would be even more annoyed to see the content I paid for disappear.

Please can someone advise? Many thanks

I had the same thing happen to me. Restarting the application solved the issue.

Keep restarting, it should solve itself!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

Why not join the Fatshark Discord https://discord.gg/K6gyMpu