Mouse lag/stuttering

I saw that somebody had posted about a similar problem in March. My game has been fine for 100+ hours. But now when I move around with just movement inputs, everything is smooth as normal. But mouse inputs have this bad stutter and has a very low sensitivity. It only happens in a lobby or level. The mouse is still smooth with normal sensitivity in menus. It doesn’t occur for other steam games as well. Is there an update on this issue?

Could you try a ‘Selective Startup’ and see if the issue persists, please?:

  1. Press the Windows key
  2. Type ‘msconfig’ and select ‘System Configuration’
  3. On the ‘General’ tab, select ‘Selective Startup’
  4. Deselect ‘Load startup Items’
  5. Reboot your PC
  6. Launch Vermintide 2 as normal, and see if the issue persists

That worked! Thank you! Would be great if you could explain what the underlying cause is though.

If you open your task manager and go to the Startup tab, you’ll have a list of programmes that are launched automatically when you turn your computer on.
The workaround Julia asked you to try prevents all these programmes from being launched automatically ; which means one (or several) of them running in the background was eating up too many resources from your computer, causing the game to lag.

It’s not as simple as that. The game isn’t lagging and its definitely not a resource issue. The game is buttery smooth when I only use the WASD inputs, its only the mouse that causes the issue. Also when I monitor my resource use I have way more capacity when the game is running when this occurs. It doesn’t occur with any other game, even with other games that are even more resource intensive, and no other steam games. So its definitely a Vermintide only problem.

Another thread in March had a reply from Fatshark that said that they had some issues where the Steam overlay would cause the mouse sensitivity to change involuntarily and that they were looking into it. I’m not really bothered if there is some other kind of conflict in this case as long as I have information on what exactly I have to shut down in the task manager to get things to work. Even as I type this, this problem has just reoccurred after a few days of the game working, and I’d prefer not to have to restart my computer every time it does.

1 Like

Are you using the SteelSeries Engine by any chance?

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

Why not join the Fatshark Discord https://discord.gg/K6gyMpu