Major fps issues

Issue Type (Required):

Performance

Issue Description (Required):

i’ve been having major fps issues since yesterday and i can’t seem to find a fix on my end. i read a post on reddit saying they were having issues as well but i’d like to know if it’s more widespread than just a few cases. as far as i can tell, nothing has changed on my end. i did update my nvidia drivers today, hoping it’d maybe fix the issue, but it didn’t. is it a server issue or something else?

even when i’m in the ship just walking around, it stutters, so it’s not like there’s a lot of stuff going on.

[PC] Do You Use Mods? (Optional):

Yes, and I’ve tried disabling them

Reproduction Rate (Required):

Constant (100%)

Platform (Required):

Microsoft Store (PC)

2 Likes

@TakoyakiGremlin, sorry to hear this. I recommend running through our performance solutions here:

Please let me know how this goes!

sorry for the delay! i’ve tried doing everything in the FAQ you provided and although there was an nvidia driver update, i’m still having the same issues with the frame rates. it’s been better since i updated the drivers but i went from zero issues just a few days ago to getting actual pauses in-game now.

i’ve also checked my internet connection in case it was something to do with that but everything is fine on that front. my upload and download speeds are what they should be and no other games or streaming services have seen a drop in performance over the past few days.

since the driver did help a bit, i’m inclined to think maybe it has something to do with optimization? but then on the other hand, it also kind of feels like it’s like server lag since it’s inconsistent and doesn’t seem to have get better or worse according to what’s going on in-game. there are times where i’m mid-horde and it’s fine, while other times we’ll just be moving to another area with some special spawning in and it’ll start to skip around.

edit: found a post on reddit of the issue

a user commented:

“That is not lag. That is a load pause. Probably due to the shaders not being precached properly so they have to load dynamically during the action. This usually happens when they have an update that doesn’t flag the setting to precache the shaders again so the client loads without all the shaders precached. This seems to be an issue with this autodesk stingray engine - Helldivers updates have had this happen a couple of times too. If they don’t have some way to manually trigger the shader precaching for the xbox then they need to add it.”

is this something to be fixed on our end or yours?

1 Like

had similar issues today, lacking some 20-30 fps from the usual capped 144fps at the mourningstar.
I714700k
Rtx4080
32 gb

for what its worth clean install of the latest, 599.something drivers + file verify fixed it for now.

steam did re-download some 2.3mb file of all things.

after a shader build from scratch it was back to normal again.

1 Like

how do you do a shader rebuild?

well after the file verification the sharder builds anew at the first bootup of the game.

like dead island 2 preloading its shader every time the game starts, darktide does so seemingly after an update or verification of files.

1 Like

other than any mod-related stuff and the user settings file, is there anything else i’d need to backup before doing the repair if i just wanna jump back into the game right after?

nope, so far after every verification there was just re-enabling the mod framework, other than that your golden.

maybe that was even the 2.3 mb related download considering the game “fixing” something about the .exe, who knows.

but yeah, new drivers + files the game was fine again, switched from september old nvidia ones solely in the hope of better dlss3 support.

I’ve noticed some serious fps drops in the last few days for the first time ever using the same powerful machine and same settings as before.

No idea how to repro but I’ve noticed it.

I hope this works for me. I’ve had a broken frame rate for about 2 months now. Idk if this can be fixed on Fatshark’s end but this is really awful, I’ve had the game since launch and it was fine until 2 months ago and now its just random drops to permanent 20 fps or lower

fingers crossed,

i only encountered the problem in the first place by reluctantly updating my drivers (if it aint broken…and all that) to the second latest nvidia one in hopes of better dlss3 support.

what gave my frame dips away was my oled monitor flickering, something that only occurs when wild frame fluctuations take place.

usually i’m rock solid at 144 fps, where its capped as well (with the odd dip in the thick of auric maelstrom spawns) so fps display was unnecessary
and a potential burn in candidate.

so i was surprised to say the least to find my mourningstar halway at 110 fps with the same settings.

now i can’t promise what exactly did the job for me:
•the clean install
•the latest driver
•file verification

this sequence though made the most sense to me and so far game’s running as usual again.

hope you get your issue fixed as well :+1:

1 Like