Launcher connection problem and random disconnects in game

Hello,

I had been playing Vermintide 2 for the past year or so without problem, but the past couple days it has become impossible to play.

Symptoms:

The launcher used to appear instantly, now takes several minutes, and when it does appear the Play buttion is greyed out with the message “Can’t start: Problems connecting to backend”.

Also when I try to close the launcher without proceeding to the game, the launcher window disappears but it never disappears from the task manager unless I force it.

After waiting a few minutes of wait the backend conneciton error goes away by itself, the game launches somewhat slowly, when I log in to the lobby there is no gameplay lag.

However every ~10-15 minutes I randomly get disconnected and the game crashes.

Solutions I tried:

I have tried validating the game files via steam, tried repairing Easy Anti-Cheat via the executable file, checked to see these aren’t blocked by windows defender, tried disabling windows defender completely, tried resetting router, checked for driver updates, checked for steam updates, tried reinstalling the entire game out of desperation.

Also I’m only having this problem with Vermintide 2, not other online games.

Any help would be appreciated

Providing some console logs

console-2021-12-29-14.45.14-b4e2800d-1709-4b65-bda3-d57c92080813.log (297.6 KB)
console-2021-12-29-15.14.21-ca116b54-7b79-4ec4-ab5a-c33a3cb68d7b.log (124.6 KB)
console-2021-12-29-15.34.27-fdb36c2e-d76f-4c92-84c1-6b96741e627e.log (76.5 KB)

And below should be the crash log from today, game seems to crash during the first loading screen before lobby.

GUID: 01134da9-4144-4c54-bca6-f3ac1cef7191
Log File:
Info Type:


Could you try our ‘Launcher Workaround’ and see how it runs?:

  1. Right-click Vermintide 2 in your Steam library
  2. Select ‘Properties’
  3. Select the ‘Betas’ tab
  4. In the dropdown, select ‘Temporary Launcher Workaround’
  5. Restart Steam
  6. Launch Vermintide 2
  7. Select the ‘Bypass Launcher’ option
  8. Click ‘Play’

Hello,

Thank you for your response. I did as you suggested, and was able to bypass the slow launch, but the game still freezes at the loading screen after the intro cinematics, before reaching the lobby.

Eventually I am forced to shut it down via task manager.

Hmmm, if you switch back to the “normal” launcher, are you able to select the ‘Modded’ realm option and does it launch normally?

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

Why not join the Fatshark Discord https://discord.gg/K6gyMpu