KNOWN ISSUE: nonexisting_channel / Error Code: 2001

Getting it since 1.0.8
on steam, If i don’t get disconnected while loading into the communal hub, I can usually make it to the vendor and then get it
console-2022-11-25-04.20.20-79349ded-7ec4-4c59-a0e0-4917b81d195c.log (872.7 KB)

Issue Description:
I get 2001 error every ~30 seconds while in a round. Enemies start skating and floating through the level. I can see other players moving, and they can see me moving. But can’t see or interact with enemies. Can reconnect and it’s fine for 30s~1 minute.

The log from 11/24 has a whole round with at least a dozen disconnects/reconnects. The log from 11/25 has a single disconnect and game quit.

Crash Report (If Applicable):
Game doesn’t crash.

Steps to Reproduce:
Play any level. Constant disconnects in game. Have not had trouble staying in the hub, or had other crashes.


Player ID:

Approx. Time of Issue & Timezone:
[11/24/2022, 3:45PM] [Eastern Time]
[11/25/2022, 10:25AM] [Eastern Time]

Upload Console Log:
console-2022-11-17-19.10.34-84f7cf83-f728-4069-bf3a-e25812c7ba53.log (777.9 KB)
console-2022-11-17-21.34.35-3d7ec8c4-0d12-4ccf-972b-75cd47869769.log (440.7 KB)

Hi all.
The game is loaded, the menu is connected. I can’t enter the game. Server Error 4008
user_settings.config (3.0 KB)

Yeah i made a report here somewhere and was gonna praise fatshark that they successfully brought down the number of times error 2001 booted me to about 40% AND if i reconnected it didnt boot me again
HOWEVER with update 1.0.8 yall broke something and now i get it 90% of the time and reconnecting doesnt fix the issue

Issue Description:

At the end of every mission i got disconnected with error 2001, and for some time after reconnect, mission ends and i don’t reach any progress for contracts.

Steps to Reproduce:

  1. Start any mission
  2. Get disconnected near the end of it
  3. Reconnect


Player ID:
[Steam Community :: DJHanter]

Approx. Time of Issue & Timezone:
[11/23/2022, 00:40AM] [Kazahstan]

Reproduction Rate:
Constant (100%)

Upload Supporting Evidence:
[Screenshots, recordings, links to Twitch VODs, etc.]

Upload Console Log:
console-2022-11-22-17.16.22-aee3b79f-fc68-42b0-b44c-3d65e8e85492.log (532.6 KB)

Upload darktide_launcher.log:
darktide_launcher.log (535.1 KB)

IMPORTANT! We have released an experimental branch in Steam, which includes:

  • POTENTIAL Backend Error FIX. We understand this hasn’t worked for everybody, and are continuing to investigate
  • Additional logging for internal_error (Error Code: 2007)
  • Additional logging for nonexisting_channel (Error Code: 2001)
  • Additional logging for various GPU-related crashes, AND A POTENTIAL FIX!

Please note that the additional logging supports our investigation and will not necessarily solve the underlying issue for you at this time. We encourage anybody with these issues to use this branch, so we can continue work on addressing these issues as quickly as possible.


  1. Open the Steam client
  2. Right-click Darktide in your Steam library
  3. Select ‘Properties’
  4. Select ‘Betas’
  5. Enter the password cTYPtKTsfMDsLHAV
  6. Select ‘Check Code’
  7. Select the ‘None’ dropdown, and experimental - Experimental Builds should now be within the list
  8. Select experimental - Experimental Builds
  9. Close the pop-up window
  10. A 1.8GB download should now start
  11. Play!
  12. Post here to let us know the outcome

My 2001 and 2007 crashes were infrequent before this patch. I haven’t noticed any after a few matches since downloading the patch, but I am noticing a significant drop in FPS.

Read the instructions on the forum. Completed. Experimental mode activated. The result is the same. Error 4008.

Here is the log.

console-2022-11-26-13.20.09-c4ec8a04-bbe2-4546-bafe-dca531faa41a.log (54.3 KB)

This is for Error Code: 2001, or were you experiencing this prior to Error Code: 4008?

Error 4008, screenshot?

Errors 2001\7 no

I have been crashing a lot (usually at least once per mission up to every minute or so) even in the closed beta (Windows 11) until I turned down my Worker Threads to 1 – no crash with that, but performance (especially in hordes) dropped to 15-30 FPS.

I swapped to the experimental branch today and set Worker Threads back up to 13. I have played 2-3 missions so far and I have not crashed once yet. I may just be getting lucky but so far, results are promising.

Joined experimental branch : Worse than before, now game freezes computer mid-game.

We very recently put out a problematic update to the experimental build which we have since reverted. Please restart the Steam client, stay on the experimental build, and try now!

Having tested the same issue also arises for me on the experimental build. Instant error 2001 upon loading into the map of a mission.

edit: saw your previous comment on the problematic branch update. Will try again with new update.

I just tried on the experimental build, I still got instantly disconnected. On a reconnect it almost worked before the game crashed entirely.

Copied the crash report here, in case that’s helpful in any way.
GUID: 985e7a9b-735c-4c59-af7b-118dd5bca280
[Crash Link]:

console-2022-11-26-17.03.00-985e7a9b-735c-4c59-af7b-118dd5bca280.log (142.6 KB)

Same thing…I got disconnected once I start playing the game after encountering NPCs.
GUID: d10b5eac-29e9-4c43-ae85-2baac0365212
[Crash Link]:

console-2022-11-26-17.54.32-a697ebb0-8269-4107-9050-0852c6825821.log (133.2 KB)

Issue Description:
Game crashed onto the windows screen after error 2001

Steps to Reproduce:
[Please add the steps that can help our QA department in reproducing the issue. For example:]

  1. Play Smelter map as Ogryn (Skullbreaker)
  2. End the mission
  3. Observed Error


Player ID:
Steam ID: 76561198314731519

Approx. Time of Issue & Timezone:
11.26.2022, 23:00PM UTC+5

Upload Console Log:
console-2022-11-26-17.45.17-03a91f1c-76f4-4ea8-af76-3ee621449408.log (191.7 KB)