KNOWN ISSUE: Input Lag, Actions Not Registering Correctly

We are aware of various complaints concerning input lag, and actions not registering correctly.

In some cases, your issue may be related to this:

Failing that, please help us investigate by including the information listed below in your report:


Issue Description:

Platform:
[Steam/Microsoft Store]

Player ID:
[Steam ID/Steam Profile URL/GamerTag]

Upload Console Log:

  1. Press the Windows key + R
  2. Enter %appdata% within the search input and select ‘OK’
  3. Navigate to AppData\Roaming\Fatshark\Darktide\console_logs
  4. Locate the console log that corresponds with the session in which the issue occurred, by looking at the timestamps in the log names
  5. Upload here

Upload darktide_launcher.log:

  1. Press the Windows key + R
  2. Enter %appdata% within the search input and select ‘OK’
  3. Navigate to AppData\Roaming\Fatshark\Darktide
  4. Locate the darktide_launcher.log in this directory
  5. Upload here

Existing reports may be merged here, to help us keep track of the issues being reported.

1 Like

Issue Description:
So I’ve made a thread about this in the Bug reports forum but I haven’t really gotten anything back from that, and because this is such an annoying problem that makes the game genuinely unplayable I figured I’d try here instead and see if any one else has this issue or perhaps even a solution.
So the issue is that when I am playing the game, a lot of the times when I’m attempting to perform an action, whether it swapping my weapon, reloading, using alt fire to activate weapons such as chainswords or thunderhammers, push attack, pulling out my grenade, activating my ability, really anything but moving, the game will perform that action and play both sounds and animation for a split second and then cancel it, sometimes multiple times in a row. This is entirely sporadic, but occurs in every match I play, but doesn’t occur in the psykhanium or prologue which to me tells me it’s a server issue of some kind.
I’m using wifi and have a download speed of roughly 150 to 200 mbps, and don’t seem to have any packet loss. My connection to the servers appear to be fine, I don’t get any lag issues other than these input glitches.
I’m just posting this here as well just to see if any one else has had this issue or knows a fix for it, because it’s becoming quite unbearable to play especially since it’s so random, some matches it will only happen a few times where as others it happens constantly, but it always happens every match.
Steps to Reproduce:

  1. Play a match

Platform:
Steam

Player ID:
[Steam ID/Steam Profile URL/GamerTag]

Reproduction Rate:
Constant (100%)

Upload Supporting Evidence:

00:06, try to activate the Thunder Hammer, it cancels
00:10, try crouching, it cancels
00:24, try swapping weapons, it cancels
00:40, try swapping weapons, it cancels
01:10, try sprinting, it cancels
01:19, try activating thunder hammer, it cancels
01:40, try sprinting, it cancels
01:49, gun continues fire animation after done firing
01:54, try swapping weapons, it cancels

Upload Console Log:
console-2022-11-25-05.19.23-aaf4cae7-c1b6-4466-818f-615d5941a454.log (19.6 KB)

Upload darktide_launcher.log:
darktide_launcher.log (105.8 KB)

user_settings.config (3.3 KB)
Here’s my config file as well.

4 Likes

Having the exact same issues to this, just significantly worse/more pronounced.

4 Likes

We’re looking in to this. Sorry I have no solutions at this time.

1 Like

Update: Since release this seems to have gotten worse.

2 Likes

I also had Problem with these Lags although the frame rate is stable.
This could be caused by so-called Memory Leak.
Restarting the game should help with that (it helped for me).
So i restart the whole game every 3rd or 4th map.

Many games have this problem in the beginning until the devs was able to find a way to fix that.

It is not a memory leak, it happens every match, and doesn’t happen when I’m in “singleplayer” sections such as the prologue or psykhanium. I monitor my memory, cpu and gpu usage, and none of them are spiking, and using a VPN does alleviate it but doesn’t get rid of it, which makes it quite clear there is some sort of connection or server issue causing it.

That’s very strange. For me the issue has since resolved itself since launch. I wonder if it was my isp because I was going back and forth with them as well so maybe they fixed something. Very hard to tell.

Same issue for me. I struggle to log in, and in the rare chance I get to log in and join a game, I get these issues except it’s much more pronounced. Definitely server side as no such issue in prologue.

Has there been any fix at all to this? I feel like this issue is getting progressively worse with each patch that comes out to the point where I’m starting to skid across the map with no input, making this game just that much worse to try and play.

So an update.
I seem to have fixed this issue, by uninstalling Avast anti virus. After I uninstalled it the input issue I’ve been having disappeared.

We kindly ask that you complete the questions below. With this information, we can investigate your issue properly.


Experiencing massive input lag with movement and combat commands. It’s like the game is queuing input commands an executes them much too late. Cannot control character. Just sliding off in one direction without being able to control. Happens almost all the time when moving or inputting commands. Didn’t observe these issues in the tutorial. Starts just as I enter the morning star. And in every game sequence. Maybe it’s a lag problem I dunno.

Crash Report (If Applicable):
[Please see instructions on how to provide a crash report in the pinned Topic]

Error Displayed (If Applicable):

Steps to Reproduce:
[Please add the steps that can help our QA department in reproducing the issue. For example:]

  1. Play Chasm Logistratum as Ogryn (Skullbreaker)
  2. Attempt to pick up the second Grimoire
  3. Crash

Mission Name (If Applicable):

Platform:
[Steam/Microsoft Store]

Player ID:
[Steam ID/Steam Profile URL/GamerTag]

Approx. Time of Issue & Timezone:
[MM/DD/YYYY, 00:00AM/PM] [TIMEZONE]

Reproduction Rate:
Once - Rare (<10%) - Unusual (<25%) - Common (<50%) - Often (<75%) - Constant (100%)

Upload Supporting Evidence:
[Screenshots, recordings, links to Twitch VODs, etc.]

Upload Console Log:

  1. Press the Windows key + R
  2. Enter %appdata% within the search input and select ‘OK’
  3. Navigate to AppData\Roaming\Fatshark\Darktide\console_logs
  4. Locate the console log that corresponds with the session in which the issue occurred, by looking at the timestamps in the log names
  5. Upload here

Upload darktide_launcher.log:

  1. Press the Windows key + R
  2. Enter %appdata% within the search input and select ‘OK’
  3. Navigate to AppData\Roaming\Fatshark\Darktide
  4. Locate the darktide_launcher.log in this directory
  5. Upload here
1 Like

It’s a shot in the dark but do you think this could be related to your issue at all?:

  • If starting Darktide in Fullscreen, and you interact with another window during the Easy Anti-Cheat pop-up, Darktide will not launch in actual Fullscreen and the FPS is impacted considerably

no i think not. these issues occur every time i play.

Crash Report (If Applicable):
na

Error Displayed (If Applicable):
na

Steps to Reproduce:
[Please add the steps that can help our QA department in reproducing the issue. For example:]

Not sure but try:

  1. Enter the training room and press the mouse scroller like you would if you were tagging something in a mission.
  2. Attempt to move around normally.

Mission Name (If Applicable):

Platform:
Steam

Player ID:
SugarfreeST

Approx. Time of Issue & Timezone:
Afternoon of 26/11/2022 UK time

Reproduction Rate:
Constant 100%

Upload Supporting Evidence:
na

Upload Console Log:
na

Upload darktide_launcher.log:
na

I have the same type of performance issue. The sound also bugs out on these incidents.
It looks like my character is blocking/aiming etc. 100 times a second or the game is lagging/stuttering. Have this on almost every mission.
With everything on low settings its less often but still too frequent to play the game properly.

I have been experiencing the same issues. I.e. my character keeps running into the same direction, is stuck performing an action such as quelling, charging a heavy attack etc.

This happens both in the hub area as well as during matches. I have tried yesterday, twice, once after switching to fullscreen and once more a couple hours later after having closed the game (meaning it launched in borderless fullscreen), as well as this morning (like 3 hours ago). The issue is very much the same.

When typing into the chat window and the lag happens, it’d input whatever character I was typing at the time, multiple times, for the remainder of the lag.

I have also tried playing around with the graphics settings, but they don’t seem to be causing the issue and I have enough memory available. Aside from that issue the game is running fine also.

Attached my last two logs:
console-2022-12-01-07.24.41-90ffdc38-3375-40cb-b121-7b3ffab00346.log (148.9 KB)
console-2022-12-01-08.12.58-a56c26ca-02ae-4a6e-82d1-dd2a5f362619.log (200.4 KB)

Im having this issue too, I usually have a very stable connection in games

Hello I have the same problem that just happened today: my character moves very badly in the hub or in part mouse and keyboard shift and unplayable, yet between yesterday and today I haven’t changed anything and that walk well before, someone is where the problem comes from?