Highly annoying microstutter present in all scenarios

Just started noticing this issue more and it’s starting to annoy me. Every so often I get this little hitch or microstutter when playing the game. The Steam FPS counter doesn’t pick it up. Can’t verify what’s actually happening because MSI Afterburner no longer wants to work with my game on my system. I do have some monitoring outside of Afterburner and everything seems to be the same as it has always been. I don’t even know when I started noticing this issue. It’s much worse when connection to the host is bad. Like unbearably worse.

I had a thought that it might be mods so I disabled all of mine. The stutter or hitching is still there. Not sure what else to try because it doesn’t seem to be associated with any particular setting. Haven’t tried a reinstall. But like I want to do that.

I didn’t start having this issue until the 1.6 patches, and I have a beefy PC. Zero issues before the last few weeks. The fact that I’m even getting this at all makes absolutely zero sense.

My specs:

9900k 4.7 ghz
32 GB 3200
2080ti

Edit: Just tried moving my game install to a different SSD. Original install was on a NVME PCIE SSD. Moved to a SATA SSD. Stutter is still present and seems to be pretty much the same. Maybe less? Probably anecdotal just based on when I was actually noticing it. Was monitoring FPS with Steam overlay. No noticeable dips in FPS when the stutters occurred. Going to try a clean install on the NVME drive later this week. Don’t have high hopes for it doing anything to fix the issue.

Clearly this is a game issue because I didn’t have this before the 1.6 patches.

There is already a Thread for this exact issue, in fact it is pinned in this category :stuck_out_tongue:

http://forums.fatsharkgames.com/t/fps-drops-stutters-and-your-dxdiags/

2 Likes

Whoops, didn’t even see it because it was locked and inactive.

I revisited the issue already today and did the following:

  1. Verified game files in new install location ( I moved the folder with Steam)
  2. Tried DX12 - stutter still present - also changed Max Stacking frames to “1” - no change
  3. Back to DX11 - changed max stacking frames to 1 - no change.
  4. Changed to Borderless Fullscreen, Max stacking frames at Auto, no other settings changed, with all mods off - Stuttering is GONE! I played an entire game without a single hitch. Smooth framerate.

I have no idea why this is happening. A few patches ago, say maybe 1.4, I was having horrible stuttering when I played IN Borderless Fullscreen. Had to switch to Fullscreen to solve it. Now it’s the opposite. Totally bizarre. Hopefully this info can be helpful to the devs!

Indeed all very useful information. Thank you!

I’ve tried both Full screen and borderless fullscreen, no luck. I only get the stuttering on DX12 though. On DX11, I just get really bad FPS during hordes.

A few things:

  1. What do you have in terms of CPU and RAM? Dual channel RAM I assume?
  2. Given the CPU that you have, what are your Worker Thread settings at in the launcher?
  3. What resolution are you playing at?
  4. What do your graphical settings look like? Do you have any CPU intensive settings on High or Extreme?
  1. Not a good CPU, an i7 older version, but I was running the game on high with no issues for around 800+ hours. 24GB of RAM, I use to run 32GB on Windows 7, but for some reason with windows 10 it won’t recognize it. Either way, as I said, I’ve was running the game fine for 800+ hours with no issues.
  2. I’ve tried moving it around, from 1 worker thread to 6, doesn’t affect my FPS or the stutters.
  3. 1920x1080
  4. I’ve tried with the game on high settings and everything turned off or on the lowest they can go. There’s no difference in performance between the two. Anytime a horde comes, I drop to 18-22FPS on DX11. On DX12, the game just freezes all the time. Haxorists posted a good video of exactly what happens. Here’s the video,

Just as you can measure frame-rate and choppiness, you can also measure stutters, micro-stutters or judders however you like to call it, using the very popular tools like afterburner, evga precision etc. Afterburner works perfectly fine with this game. Maybe try to install the latest version.

Stutters and micro-stutters can be easily measured by taking a frame-time graph. While frame-rate counters will fail to tell you where you are micro-stuttering or even stuttering, a frame-time graph will be able to tell you very precisely. Take for example, the below video. Afterburner is asked to level all frames under 16.6 ms in this video for a buttery smooth 60 fps. That’s why you see a completely flat graph. This is the ideal situation where every frame is rendered within the 16.6 ms budget. When a frame takes longer than that, especially if it takes significantly longer, it creates the sensation of a stutter (or micro-stutter depending on how long it takes). And, afterburner throws it as a spike on the graph. In the below video, there is no spike during gameplay. But, several spikes when people joined, when game loaded, and when game finished etc. etc. demonstrating that the engine is stuttering at those times (but those are very normal things if games are loading and what not).

Here is how you see it: https://imgur.com/a/SCpXPWW

Alright, so I went ahead and ran the benchmark test with my settings.

capped12

74 FPS. And that’s with settings on high-medium. Yet in game, 18FPS during a horde… even on the lowest settings. Again, I had no issues for 800+ hours. What am I missing?

That’s nuts! I’m gonna test when I get home and will report back.

Thanks for the explanation, but no, this game no longer works with Afterburner for me. The OSD does not show up at all when running in Borderless Fullscreen mode. It did before, because I was running in the same display mode when I first built the PC I am playing on. Now it does not. I reinstalled Afterburner just because of this issue and it still persists. I tested Afterburner in another game and it works as it usually does.

That said, I am aware of what frame time monitoring is and I don’t need a frame time graph in order to determine when I’m experiencing stuttering. It was palpable during normal gameplay. And as I mentioned above in my previous post, switching display modes seems to have fixed my issue. I have done some additional runs today without any stuttering like I was experience. I even turned my mods back on. No stuttering.

I watched your video and now I’m confused. You’re playing on PC but the video shows the UI from the console versions. Are you using a mod of some sort? Or what?

It’s in the options, you can turn on the controller layout.

btw, I got so annoyed last night. I went ahead and built a new PC with all the spare parts I have laying around the house. Gonna do some tests today and see how it runs.

Had an MSI motherboard with a watercooled i5 CPU. Threw in the 32GB of ram and a GTX 1060. See how it works today.

Well, running the game on default high settings. Getting 85FPS on average which is a big improvement.

bench

CPU is hitting around 50C, again an improvement.

cputemp

GPU is pretty much the same, 67C which is the highest it got on my old rig.

gputemp

Eitherway, it’s an improvement in FPS and I didn’t notice any stutters or FPS drops. I’ll test it in game after I feed the kid and see for sure.

Just curious, is anyone else having these stutters using an i7 CPU?

Yep, all is well now. No frame rate drops during hordes, with the settings I use for better visibility during rat slaying. I get around 100FPS on average, no spikes or drops. Even if I turn on Vsync, FPS stays at 59FPS all the time and never moves, ever. So I guess one way to fix the problem, grab a new motherboard an use a i5 CPU lol…

2 Likes

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

Why not join the Fatshark Discord https://discord.gg/K6gyMpu