[help] i cannot see new game launcher

I cannot for the love of Sigmar get my game launcher to display the new UI… you know, the one with the Warrior Priest and all the Fatshark news. So far, on Windows 11, I have tried:

  • Verifying my game install files
  • Installing (and repairing) Microsoft Edge WebView2
  • Setting V2 steam properties to “temporary beta”

I know this probably sounds like a silly things to ask for technical support… but I really just want my game launcher to be up to date like everyone else :frowning:

I believe I have responded to your post in the Steam Discussions. :slight_smile:

I’m trying to update my game launcher to the new version (where you get news and a live image of the warrior priest)… but nothing is working. I’ve tried manually installing the Microsoft Edge WebView2 runtime file but it keeps telling me that “it’s already installed.” Any suggestions?

My Specs: Windows 11 Pro, Ryzen 5800X, GTX 1080, 32GB RAM

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

Why not join the Fatshark Discord https://discord.gg/K6gyMpu