Game wont work with NAT router

i tried all the port forwarding, the game will not work unless i dmz or shut the firewall down.

can you give me the correct ports and settings?

Vermintide doesn’t have specific ports. Do you have Steam port forwarding set up?

Forward for both
27000-27050
50000-65000

Do you have other multiplayer Steam games, and if you do, can you play those?

ive tried using my nat and steam and it does not work, even if i forward ports, the router has a built in steam setting as well but it did not work.

is there something else i have too shut off like upnp?

UPNP you generally want on. Some routers have a terrible or only semi-functional implementation of it though.

I would check your Firewall settings and confirm that you have VT2 allowed through, and that there’s nothing funky like you have it approved for “Private” networks but your connection to the network has managed to become flagged “Public” instead.

^ This. Try with your firewall off, and btw, which Antivirus do you have?

works with router firewall off not problem so its not my windows fire wall or anti virus at all.

my only issue is with router nat firewall on.

It’s probably your router then. Are you running stock firmware or do you have something like DD-WRT going?

Someone on Reddit mentioned that being set to Strict NAT is the problem. If you’re using stock router firmware, you may not have the option to change it other than possibly disabling it.

yes

im just trying to find out the setting to allow me to use my nat firewall with the game why is this so hard?

im trying some more, seems lik the ports you gave me are different than the stem ones i tried but didnt work found here

https://support.steampowered.com/kb_article.php?ref=8571-GLVN-8711

this is my setting following your ports and it gave connection time out when trying to join a game.

Do you have DSL? Often times you’ll end up in a double NAT situation where the DSL modem has it’s own NAT that’s separate from the router. Setting the modem to bridge mode can sometimes help resolve this. If you can’t change the modem, then changing the router to bridge mode may work.

Are you behind a CGNAT perhaps?

Call your ISP and get angry if so.

1 Like

not on dls but cable. i do have a cable modem and then a nat wifi router.

i can play the game if i set the router firewal to “low” with is “allow all.”

traceroute, is this carrier grade?

Untitled

wait so there a CRGNAT in my modem, so im already behind a nat and can leave the wifi router nat at LOW and im still protected?

Hms, IPv6-wise you are not CGNAT:ed, but your IPv4 might be.

How about:

tracert 172.217.21.174

? (i.e. forcing IPv4)

Just for avoidance of doubt: NAT:ing happens on IP-level, and even though NAT:ing is possible in IPv6 it is practically (almost) never done, since you in practice have no reason to do it due to address abundance. NAT:ing (and CGNAT:ing) are done in the case of IPv4 since we have a lack of IPv4 addresses. Also not that NAT:ing is not the same as a firewall, even though the same device often does both for IPv4 in a consumer setting.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

Why not join the Fatshark Discord https://discord.gg/K6gyMpu