Connection time out with new ISP

Dear Community,

I have been playing Vermintide 2 without any issues until changing ISP.

Since then I have been unable to connect to any Vermintide 2games or are people unable to join my game. All other steam games are not affected!

It does however still work via hotspot 4g, so I don’t think the computer is the issue.

I have contacted the ISP in regards to this, but my tracert to seemed fine according to them. UPNP is enabled and firewalls are off, I have changed the DNS to an open one. And added steam p2p etc to my port forwarding.


Tracing route to []
over a maximum of 30 hops:

1 2 ms 3 ms 2 ms eehub.home []
2 12 ms 6 ms 7 ms
3 * * * Request timed out.
4 18 ms 16 ms 14 ms []
5 24 ms 23 ms 24 ms
6 25 ms 27 ms 26 ms
7 23 ms 26 ms 24 ms []
8 * 176 ms 166 ms []
9 162 ms 162 ms 162 ms
10 * * * Request timed out.
11 * * * Request timed out.
12 * * * Request timed out.
13 * * * Request timed out.
14 * * * Request timed out.
15 * * * Request timed out.
16 * * * Request timed out.
17 * * * Request timed out.
18 * * * Request timed out.
19 * * * Request timed out.
20 * * * Request timed out.
21 * * * Request timed out.
22 * * * Request timed out.
23 * * * Request timed out.
24 * * * Request timed out.
25 * * * Request timed out.
26 * * * Request timed out.
27 * * * Request timed out.
28 * * * Request timed out.
29 * * * Request timed out.
30 * * * Request timed out.

Trace complete.

I have also checked the console and found below changes (first one is with new ISP and router, second with the old).

09:49:43.341 [Steam] Accepted session request from 1100001127035ba

09:49:47.103 [Connection] Creating endpoint 1100001127035ba - inbound message

09:49:47.103 [Connection] Setting transport socket buffer size to 9600 for 512.0 kbps, this may cause a buffer latency of 0.150 s

09:49:47.103 [SteamAuthenticator] Got ticket request from 1100001127035ba

09:49:47.103 [SteamAuthenticator] GetAuthSessionTicket 1100001127035ba

09:49:47.103 [SteamAuthenticator] Sent ticket to 1100001127035ba

09:49:47.105 [Lua] [ChatManager][1]System: DELETED FOR UPLOAD is joining the game

09:49:47.123 [SteamAuthenticator] Sent ticket request to 1100001127035ba

09:49:47.184 [SteamAuthenticator] Got ticket from 1100001127035ba

09:49:47.184 [SteamAuthenticator] BeginAuthSession 1100001127035ba

09:49:47.184 [SteamAuthenticator] Authenticating 1100001127035ba

09:49:47.523 [SteamAuthenticator] Steam validation for 1100001127035ba with response 0

09:49:47.603 [Connection] Dropping packet from 1100001127035ba since remote session is unknown yet

09:49:47.843 [Connection] Dropping packet from 1100001127035ba since remote session is unknown yet

09:49:48.043 [Connection] Dropping packet from 1100001127035ba since remote session is unknown yet

09:49:48.123 [Connection] Dropping packet from 1100001127035ba since remote session is unknown yet

09:49:48.283 [Connection] Dropping packet from 1100001127035ba since remote session is unknown yet

09:49:48.524 [Connection] Dropping packet from 1100001127035ba since remote session is unknown yet

09:49:48.644 [Connection] Dropping packet from 1100001127035ba since remote session is unknown yet

09:49:48.744 [Connection] Dropping packet from 1100001127035ba since remote session is unknown yet

With my previous provider it went to:

[SteamAuthenticator] Got ticket from 11000010433ab38
19:28:36.541 [SteamAuthenticator] BeginAuthSession 11000010433ab38
19:28:36.541 [SteamAuthenticator] Authenticating 11000010433ab38
19:28:36.555 [SteamAuthenticator] Got ticket request from 11000010433ab38
19:28:36.555 [SteamAuthenticator] GetAuthSessionTicket 11000010433ab38
19:28:36.555 [SteamAuthenticator] Sent ticket to 11000010433ab38

[SteamAuthenticator] Steam validation for 11000010433ab38 with response 0
19:28:36.996 [Connection] New session id 2 to 11000010433ab38.
19:28:37.036 [Lua] PlayFabMirror:_commit_internal 4
19:28:37.036 [Lua] [PlayFabRequestQueue] Enqueuing ExecuteCloudScript request updateCharacterData 5
19:28:37.036 [Lua] ---------------------- BackendInterfaceStatisticsPlayFab:save ----------------------
19:28:37.037 [Lua] generate_backend_stats 110000103224d52:1
19:28:37.044 [Lua] [BackendInterfaceStatisticsPlayFab] No modified player statistics to save…
19:28:37.051 [Lua] [PlayFabRequestQueue] Sending Request Without EAC Challenge ExecuteCloudScript updateCharacterData 5
19:28:37.115 [Connection] Established a connection <2.243> to 11000010433ab38
19:28:37.115 [Lua] MatchmakingHandshakerHost:rpc_matchmaking_handshake_start()
19:28:37.115 [Lua] [Matchmaking] Got a handshake request from 11000010433ab38 with user name ‘DELETED FOR UPLOAD’
19:28:37.235 [Lua] [Matchmaking] Got request to join matchmaking lobby 186000001b7f42c from 11000010433ab38, replying lobby_ok
19:28:37.320 [Lua] [PlayFabRequestQueue] Request Success ExecuteCloudScript updateCharacterData 5

I think it’s still an ISP problem, but don’t know how to form the question to them or which area to investigate, would it be possible to assist me in this matter?

Happy to provide more info, but have done multiple router restarts/resets and DNS flushes. (as per other topics without any solution.

Please include as much information as possible in the description of your issue and include any crash reports produced (if applicable).

If you have already submitted your issue via the Fatshark Support Portal, please avoid double-posting here. You Support Portal query will be answered within 24 hours, Monday to Friday.

1 Like

Sorry to hear about your problem. This is certainly ISP/router related and I’ve asked if one of our Network Engineers could check this out next week, in hopes that they can advise on how to proceed.

With the Christmas break upcoming it may not be possible for them to look in to this until the new year, but I hope to catch somebody on Monday.

1 Like

You are behind a CGNAT. Ask your ISP if they can get you a proper IPv4 (i.e. one not behind a CGNAT).

Ping me if you need help formulating your request.


Thank you Julia,

There is no rush, I fully understand, everybody deserves a break!

Enjoy your weekend.

Hi Empizza,

Thank you for your reply, when providing them with your answer they came back with the following: 'Only the EE mobile network employs CGNAT. But you are on fixed BB which doesn’t. It is also IPv4 only.

EE doesn’t utilise CG-NAT for their broadband networks.
Have you tried using a VPN?’

I haven’t tried a VPN yet.

Interesting. Did you change router when you switched ISP as well? Do you know if your current router supports UPnP?

(You described a common CGNAT problem, so I just assumed it was. Cudos to your ISP though.)

If you are unsure about UPnP, use miniupnp to test it. Latest version


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

Please pardon my last message in which I said this was ISP/router related - it’s not - it’s an issue on our part and will be addressed with the next patch. Apologies for the inconvenience.

1 Like