Game random crashes and files going corrupt (SOLVED)

Hi guys,

Issue Summary:

Since 1.5 my game is constantly crashing (yes all hotfixes are installed, same every time). I was only able to finish one game. The crashes are different since behaviour. Sometimes I only start the game and it directly has corrupted data (no mods used) sometimes even when I check the files via steam before.

Sometimes I do get into the lobby and it crashes then in the lobby (also files corrupt) and sometimes while joinging a map / keep.

Other then those some random crash to desktop happen as well (without the warning of file system).

DxDiag.txt (84.8 KB)

Reproduction Rate (Choose One):
Constant (100%)

Additional Information:
Last crash:

GUID: 915e9ab8-2d67-4d5b-8c44-2d12421997e8
Log File:
Info Type:


console-2019-02-21-18.16.42-AD331F21-F48C-4AA9-B19C-3FE6.log (388.7 KB)

Sorry guys, but this is really the worst you have done so far. Please introduce betas again …

I cannot play since the release and its just sad to see this drop in quality.

Kind regards
Ver0n

So it sounds like there’s a couple of issues occurring here.

Firstly, the crashes you’re experiencing are called Access Violations which (in our experience) are usually caused by something local. It’s unclear as to why this would have began after 1.5 and something we’ll consider, but there’s a list of potential solutions here that you may need to run through.

The data corruption is a bit more complicated, it’s possible the solutions in the link above could help, but otherwise I’d recommend reading through this.

Thanks for the guides, Julia.
For future reference: here are my problems and how I solved them.

  • I followed the steps from the links. My issue seems to be the " Potential Cause: Visual C++ Redistributables". I had 32 and 64 installed. I don’t why or how but they were apprently corruped. I uninstalled both and only reinstalled the 64 version. This was leading to my game running (for a bit)

  • After that I encountered another problem. What initally looked like another CTD turned out to be a blue screen. I researched the logs and message of the bluescreen and came acorss a reference regarding faulty memory. I had the windows internal check “Windows memory diagnostic” running and to my suprise: it found “something”. So I crosschecked by having my PC run with only one RAM module at the game and indeed found one to be faulty. After that I could play.

  • 3rd problem after that, altough this is not related to the above, was the micro stuttering that is to be experianced in recent windows 10 versions. The fix for me was the use of a bat file which deletes the standby memory every 5 mins, if it hits a certain amount as well as a small tool called “TimerTool.exe” which lets you adapt the response time to the one of your monitor. In addition to that a little bit of flickering was still noticable in game, which was then fixed by using V-SYNC.

Hope this helps somebody in the future. Good luck and thanks again, Julia.

1 Like

Nice work @Ver0n! I appreciate the update. :slight_smile:

1 Like

You’re welcome. :upside_down_face:

Just another small addition to this: the micro stutter has happend to me in the version 1803 of windows (up-to-date as of this post). Installing the correct / latest intel chipset driver also helps. I’ve noticed, that some driver tools (for example from software of mainboard manufactores) do not necessarly include the latest one. To make sure, that you have the latest, searhc for it on the intel drivers page. Good luck.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

Why not join the Fatshark Discord https://discord.gg/K6gyMpu