Game crashes at start and mid prologue

Please include as much information as possible in the description of your issue and include any crash reports produced (if applicable).

If you have already submitted your issue via the Fatshark Support Portal, please avoid double-posting here. You Support Portal query will be answered within 24 hours, Monday to Friday.

GUID: 0830a9e7-ac6c-473a-8d1b-8ebce664c2bb
Log File:
Info Type:


Hi @stonebullet9566

Based on the information within the logs, it appears that AMD Radeon™ Vega 8 Graphics is set as your default GPU, as opposed to your NVIDIA GeForce GTX 1650. This is consequently resulting in your crashes in Vermintide 2, as the AMD Vega 8 Graphics cannot handle the demand.

Please run through the solution steps below:

  1. Right-click the desktop and select the ‘NVIDIA Control Panel’
  2. Navigate to ‘Manage 3D Settings’ > ‘Program Settings’
  3. Locate Steam within the list of programs
  4. Within the ‘Select the preferred graphics processor for this program:’ dropdown, choose the NVIDIA GPU
  5. Then locate Vermintide 2 within the list of programs, and repeat the above step
  • For Windows 10 users:
  1. Navigate to ‘Settings’ > ‘System’ > ‘Display’
  2. Select ‘Graphics Settings’
  3. Select the ‘Browse’ button and locate the Vermintide 2 executable (Program Files (x86)\Steam\steamapps\common\Warhammer Vermintide 2\binaries)
  4. Select the ‘Options’ button
  5. Choose ‘High performance’ and save your changes

Let me know how you get on!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

Why not join the Fatshark Discord https://discord.gg/K6gyMpu