Game causing Discord to disconnect?

I hope this is the place to post this.

Issue Description:
I havent seen anyone mention this. While the game is running fine on my end, finished the prologue and training without any issues however when I it, Discord keeps losing connection on and off. Works fine the moment I close the game. It seems the game itself or the anti-cheat is causing this. Unable to play with friends like this.

Steps to Reproduce:
The moment I start up the Pre-order Beta. Played the previous Beta fine with a friend on Discord no issues on that end then. Just now with this client of the game.


Player ID:

Reproduction Rate:
Constant (100%)

This is admittedly quite strange!

Does the issue persist after restarting your PC?

The moment Easy Anti-Cheat kicks in after the clicking Play and shaders are loaded it disconnets me from Discord.

Been trying to restart/update discord. Gonna try restart the PC now as a last attempt.

Still having the same issue after Restarting the PC. Again, the moment Easy Anti-Cheat starts up it disconnects me from Discord.

Tried out other games with Easy Anti-Cheat and they did not disconnect me from Discord. So whatever the issue is its something with this build and it happens whenever the anti-cheat opens up.

Okey so I just tried to run Discord on Firefox and I remain connected while playing. So something with the game and the discord app is acting up on my end. Tried to completely re-install Discord and the beta still disconnected me.

At least I’m able to play with friends now while using my browser. But I hope this issue with the Discord app gets sorted at some point, no idea what could cause the issue other than the anti-cheat triggering something.

Thank you for the updates @DrimDrim, and I’m glad you’ve been able to find a workaround that works for now. I’ve passed this information on internally, and we can look to resolve this with Discord.

Hello, I seem to be having this issue as well.
Whenever the game starts, Discord starts lagging like crazy and I can’t follow what anyone is saying anymore at that point. It seems to struggle with “RTC Connecting”, if it isn’t connecting. Not sure if that helps.
When I join Discord via the web app, it seems to work fine.

I have been having the same exact issues for the past week at least. Thanks for the tip about the browser Discord didn’t even think about that good call!

This issue is still present with the latest patch. The discord client is unable to connect to servers whenever I start up Darktide.