FPS Drops with WoM

Hi there,
I’m not sure where to describe my problem, but i’ll try to do it here.
After the latest update i’ve got some massive FPS drops, sometimes even lower than 30 fps, especially during hordes.
And i have noticed, that the game uses much more CPU resources (like 50-60% listed in the Task Manager).
My PC:
Windows 10
32Gb RAM
GTX 2080 Ti graphics
i9 9900k CPU

If i should provide more info - what kind of information should i provide?
Hopefully i’ll get some help here.
Thanks in advance!

Went ahead and moved your post to it’s own thread.

Can we go ahead and trouble shoot a few things? Have you tried switch between DX11 and DX12? You can do this via the V2 launcher under settings.


Are you using mods? Have you tried turning off all mods?

The i9 9900k CPU has 16 threads right? I remember reading somewhere that using more that 8 for game causes issues? In the settings on the launcher, try adjusting the “Worker Threads” for this.

You could upload one of your more recent console logs here as well,

C:\Users\YOUR PC NAME\AppData\Roaming\Fatshark\Vermintide 2\console_logs

Same for me.
Whenever a bigger Horde spawns my GPU Usage drops to 40% and CPU rises above 70%.
My FPS drops from 100-90 to 40-30.

Ryzen 1600x
GTX 1080

I already played arrount with Settings and Worker Threads nothing makes a diffrence.

Try disabling hyperthreading in bios and run game on maximum amount of physical cores.

Lets see if it helps

Thanks for the Tipp.
I disabled SMT in BIOS and set Worker Threads to 6.

Performance stays pretty much the same unfortunately. :frowning:

Did you try switching between DX11 and DX12? I get screen freezes and drops in DX12, I have to use DX11. Also, weirdly enough, I can not even launch the game in DX12 when going into the modded realm.

I run DX12. Switiching to DX11 makes it slightly worse because its much heavier on the CPU.

If you encounter Drops and Stutter on DX12 you should play 2 or 3 Maps and see if its working better.
Micro Stutter is normal for DX12 at first, the Shader Cache need some time to build up.

That beeing said, I couldnt play on DX12 either prior to WoM.
I dont know if FS made some improvements or Nvidia Drivers are just getting better optimized for DX12.

FYI - the latest NVIDIA driver has been notoriously bad for performance in Vermintide 2, in the mean time consider rolling back to 431.60.


How do you roll it back?


Or you could just download them from the Nvidia website.

Have to set the worker threads to 8 in the user_settings config file with notepad++ otherwise you can only use 6 instead of 8 cores that you have.

The other two cores are left alone for windows.

I tried everything from 2, 6, 8, 10, 11 and 12.
Dont notice any difference.

@FatsharkJulia: already did that (uninstalled with DDU).
No Change.

Never had a problem with setting it to the absolute max and having it run with anything lass than max just makes the game run worse. Maybe if you had so much junk installed on your pc that you had background apps sucking up 10-20% cpu usage it might be detrimental to set your worker threads to the max but realistically you shouldn’t be seing more than a 2-3% cpu usage combined from everything else.

I moved my Game Files to another Drive (NVME to SATA SSD via Steam) and for whatever reason my Performance got a bit better.

1 Like

Little Update:
I finally reinstalled Win10 and everything runs smooth now.
GPU Usage stays always beyond 90%

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.