Fatshark Disable Auto Exposure Everyone Hates It

I’ve included instructions how to do it in UE4

In Project Settings, go to the “Rendering” section, you’ll find the switch there it says Auto Exposure, uncheck it and voila.

If you performed your lighting pass prior to disabling AE, you will likely need to go back and brighten your scene lighting (which is what I’d recommend over doing a post-process adjustment, because you’ll keep the integrity of your value range vs. artificially flattening it).

Keep in mind that if you disable it in the project settings and then set different values via a post process volume, the volume settings will override the project settings. So you can turn it off by default in the project settings and then turn it back on via post process. Make sure if you’ve got it off in the project settings you also leave it off in the post process.

*Here’s instructions on how to add AutoExposure for Stingray so please do the opposite of this and undo it for the sake of the children’s eyes…

To add the auto exposure component to the default shading environment, click the + icon, and select Shading Environment > Auto Exposure. With this component enabled, the regular Exposure component has no effect in your scene.
To give you a visual aid in adjusting the auto exposure, the Level Viewport now includes a render mode called Auto Exposure (Full Render > Debug > Auto Exposure), which displays a histogram of the scene lighting , showing where the brightest and darkest points are, with a mini-viewport to the right displaying the luminance value of the pixels in the scene.
The main property that you’ll use to set auto exposure is the Exposure Target which adapts the scene exposure to light intensities.

To set the auto exposure for your scene:
Set up lights in your level. See Create a light source.
Add auto exposure component to the shading environment and enable it.
Depending on the light settings, your scene will appear brighter or darker.
Note: The auto exposure is dependent on where you are in the scene.
Start to tweak the auto exposure component to the eye adaptation effect that you want:
Find an “average” area in your scene and then set “Exposure Target” to a reasonable value.
Go to the brightest area and see if the maximum value (brightest exposure) is good.
Go to the darkest area and see if the minimum value (darkest exposure) is good.
Adjust the Exposure Max and Exposure Min values to decide how much the auto exposure can change to be brighter or darker.
(Optional) Fine tune the other auto exposure properties to control the adaptation speed and input threshold values the eye adapts to.

NOONE LIKES AUTO EXPOSURE IT CAUSES CANCR OF THE EYES, FIX IT

Autoexposure is that crppy effect which simulates the iris when looking at light sources and makes everything else darker, really makes the game unplayable…

Reddit Link

2 Likes

I like it.

Also they’re not using UE4, they’re using Autodesk Stingray.

1 Like

Hello Snugglefresh,

I have moved this thread to feedback, as this is not a bug.

Cheers,
Hanna

4 Likes

i like it too. if you are in a dark room and sienna flares out suddenly with a burst of unchained ulti, things are hard to see in the aftermath, and it’s glorious.

i dislike people thinking they are the source of truth for everyone. zzz.

2 Likes

I have no problem with light adjustments.
I do, however, think it’s silly how they implemented it.
They fixed some of it, like how the beamstaff made the mage using it blind, but there’s still cases where in the keep someone moves to stand in front of you and suddenly the whole screen turns a bright grey because the game is trying to adjust for the fact that they stand in front of the light.
The effect should be a lot more muted, really only being noticeable (unless you look for it) if you come out of a dark cave - those are rarely dark - and enter a brightly lit area.
Like the temple of sigmar, damn that stuff glows.

Read up on it

Stingray just announced Auto-Exposure is a bug tho, to be specific it’s a parasite class :wink:

i don’t deny the majority may feel it’s uncomfortable. i’m just irritated with false sweeping statements.

Why not join the Fatshark Discord https://discord.gg/K6gyMpu