Performance Tweak - Sun Shadows

I found a possibly huge performance tweak but is has a noticable visual impact.
After testing a lot of stuff with config files I determined the setting that impacts my performance the most are the sun shadows.
You can’t adjust the sun shadows seperately in the graphics options.
Instead I think the value is activated when you set lighting quality to medium or higher or something in that direction.

Set you graphics ingame, quit, go to

%appdata%\Fatshark\Darktide

open

user_settings.config

and change the line

sun_shadows = true

to

sun_shadows = false

You might have to make the config read only. I did. Not sure if the game resets this setting. I guess it does.

This literally makes the difference between smooth gameplay and lagfest for me.
I set everything else to high and I have decent FPS now.
Before I was playing on 900p and with this tweak I could switch back to 1080p.
I even set the amount of dynamic shadow lights to 12.

Everything the game does is ok for my hardware except the sun shadows.

This is my current settings file

Ok … after more testing I found out it apparently only does the trick for me in specific maps.
Other maps just have such messed up performance issues that this alone doesn’t help either.

When I wrote this I played a bunch of games and it worked fine. XP

Or there is something weird going on with the config file and which settings are actually used.