Fatal Error/Easy AntiCheat Error

Have been playing Vermintide 2 all month.
This evening, game will open up the launcher, but not launch the game. First message is titled “Fatal Error”, saying I need to have steam client open to play the game, which I have running.

After closing that window, and Easy Anti Cheat pops up, saying
"Untrusted system file (D:\steam\steamclient64.dll)

Tried verifying game files, said one was missing and downloaded, but error persists. Deleted certificates and ran Anti-cheat Repairer, but to no avail.

4 Likes

Same issue for me tonight. I think there was a Steam update last night? I opened a Steam support ticket, but also posting here.

Screenshot 2021-10-07 193711
Screenshot 2021-10-07 193721

1 Like

Same issue here.

I believe the latest steam client update was on the 7th of October. However I was playing fine earlier on the 7th at around 12:00 PM (EST/EDT) in the afternoon. When I tried to play again at around 11:30 still on the 7th it gives me the error as well.

The problem turned into a backend error after the steam update and still persists.

2 Likes

Iam getting this error every time.

I just got the game and was loving it! Ran into this error today and after lots of web browsing, I end up here. after reinstall, verifying files, repairing EAC…

Hey folks! We’re looking in to this one. Seems some funk between Steam itself and EAC, Steam did a rollback of an update noting EAC as a reason. We’re seeing what we need to do (or can do) on our side to see this resolved ASAP.

Thanks for your patience and sorry for the trouble caused.

2 Likes

The game works now after the rollback update. Thanks.

1 Like

It still doesn’t work for me and some others. Some people still get the backend error for some reason.

Yep, the roll back didn’t help everyone. Some folks reported reparing EAC from the game installation directory can help. The process is found here, and we’ll keep updating that page as we find out more.

1 Like

repairing and verifying file integrity didn’t help either I still get backend error.

Game is fixed on my end. I didn’t do anything, Steam didn’t update either but atm I can play the game on the official servers with mods.

1 Like

Seems to be resolved on my end, looks like steam did a small update.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

Why not join the Fatshark Discord https://discord.gg/K6gyMpu