Evacuation Bell, Legend, still bugged (2021)

Tried to make it with friends several times - did not trigger after dropping behind the ogre, nor reaching the portal. Both within 85 sec from the drop to the bell arena.

Finished a lot more games solo on HM and bots, using purple+speed potions , all within timer, and still no success.

I helped a friend do this some time ago. It took us several attempts to complete it and we came to the conclusion the timer starts as you approach the ledge, even before you drop.

For each of our failed attempts we paused a bit before the drop (to figure out who goes where, for some reason we changed the plan every time lol).
On the successful run we did not pause.

So, did you pause?

Not saying it’s not bugged, just sharing my experience in case it’s helpful.

4 Likes

Yes, i paused every time, because during most of my attempts i had a horde just before approaching the ledge.
Took my time to clear it, then snipe the adds on the arena and only after that - rush down towards chains.
Will try to re-do it keeping in mind your info, thanks.

1 Like

I did it quite recently, I hope this helps (but I’ve heard it’s inconsistent, so take this for what it is):

I’m not sure about the ledge thingy, I’d heard about it so I kept it in mind, but I don’t remember if the last time we stood there for a bit or not. Probably not.

We split up so my friend got the chains on the right, I dashed to the others, this made it even quicker than breaking them all by conc dashing myself.

The achievement unlocked right in front of the bridge of shadows for me. I used 1 purple potion with decanter (handmaiden) in the whole event, drank it right after the rat ogre appeared. My friend was way behind, he didn’t even make it inside in time, so that shouldn’t be a problem.

I’ve seen only another video of a guy clearing the event recently - for research - for him it unlocked there as well.

Putting the year into the title? Soon we will have full dates in there just to try and avoid confusing the new reports from the old ones since same content ones just keep piling up .c

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

Why not join the Fatshark Discord https://discord.gg/K6gyMpu