Easy Anti-cheat error

We kindly ask that you complete the questions below. With this information, we can investigate your issue properly.

Issue Description:
When trying to log in to the game, I am getting "Error Code:10022 (Unexpected error. (0xC0030004)). When I had the game installed on my non-Windows HDD drive this wasn’t an issue, it started happening when I moved it to my SSD Windows drive. For a while I could access the game through the Darktide.exe in the game folder. This no longer works because nothing happens when I click the executable in the game folder.

I have tried re-installing the game, which worked for a while. I have also referred to the link below to try and solve this problem.

I have renewed the Anti-Cheat certificates as well by deleting them and trying to run the game again. I cannot launch the Easy Anti-Cheat setup as an administrator or through the command prompt.

My Windows is up-to-date and I have run the file checker. I don’t think I am a part of Windows Insider program as I got my copy from Jack Sparrow, I don’t have an option to do so anyway without logging in. My connection to Xbox live is working and functions fine for other games.

I don’t have any background start-up applications or other anti-cheat programs that could be interfering with Easy-Anti Cheat. I have played other games in the past that incorporated Easy Anti-Cheat without issues including Vermintide 2.

I have never tried so hard to get a game working and I feel like I need to get an IT degree to get this game to launch. I have a suspicion that I would have been fine if I got the Steam version. Nevertheless, I don’t want to lose my progress. Thanks.

Crash Report (If Applicable):
[Please see instructions on how to provide a crash report in the pinned Topic]
GUID: e651377f-c3d1-482a-9764-7362946c8afb
Log File:
Info Type:

Error Displayed (If Applicable):
Error Code: 10022

Steps to Reproduce:
[Please add the steps that can help our QA department in reproducing the issue. For example:]

  1. Try to login
  2. Fail

Mission Name (If Applicable):

[Steam/Microsoft Store]
Microsoft Store

Player ID:
[Steam ID/Steam Profile URL/GamerTag]

Approx. Time of Issue & Timezone:
08.12.2022 18.45 PM GMT +3

Reproduction Rate:
Once - Rare (<10%) - Unusual (<25%) - Common (<50%) - Often (<75%) - Constant (100%)

Upload Supporting Evidence:
[Screenshots, recordings, links to Twitch VODs, etc.]

Upload Console Log:

  1. Press the Windows key + R
  2. Enter %appdata% within the search input and select ‘OK’
  3. Navigate to AppData\Roaming\Fatshark\Darktide\console_logs
  4. Locate the console log that corresponds with the session in which the issue occurred, by looking at the timestamps in the log names
  5. Upload here
    console-2022-12-08-15.37.48-52b617db-4a97-4bf5-9322-591ae58deb72.log (1.2 KB)

Upload darktide_launcher.log:

  1. Press the Windows key + R
  2. Enter %appdata% within the search input and select ‘OK’
  3. Navigate to AppData\Roaming\Fatshark\Darktide
  4. Locate the darktide_launcher.log in this directory
  5. Upload here
    darktide_launcher.log (282.1 KB)

This is a complicated one. Would you consider contacting Easy Anti-Cheat directly?

If the solutions listed below have not helped with your issue, please contact Easy Anti-Cheat directly: Easy Anti-Cheat

We understand Warhammer 40,000: Darktide is not currently listed in the ‘Game’ dropdown in the link above. In this case, please select Warhammer: Vermintide 2 and explain in the description that your issue impacts Darktide.

Having the same issue here

Following - same error

Same issue, I have also tried upgrading from windows 10 to 11 just to fix it. No combination of renewing certificates and re-installing easy anticheat seems to make any progress.

I have heard that uninstalling the epic games client can help, however I have not tried it yet.

Uninstalled Epic Games Launcher, didn’t help. Also try searching for all versions of EasyAnticheat and uninstalling via the Setup option. Didn’t help. Have tried logging a call with EAC but have yet to have a reply.

This might help as I managed to get it working! I moved the EasyAntiCheat directory (I was using the PC XBox Game Pass version) from the Content folder and in to the main Warhammer folder. I deleted the certificates folder and used the following instructions to run the command prompt as below. I had to rename the path to Warhammer 40,000- DARKTIDE as for some reason there was a hyphen in the path.

    1. Navigate to: C:\Program Files\Steam\steamapps\common\Warhammer 40,000 DARKTIDE\EasyAntiCheat
  1. Delete the ‘Certificates’ directory
  2. Open the Command Prompt
  3. Enter and run the command below:

“C:\Program Files (x86)\Steam\steamapps\common\Warhammer 40,000 DARKTIDE\EasyAntiCheat\EasyAntiCheat_EOS_Setup.exe” install 7acc27ad90f7456f9ca9cf05bb7ef6db

  • Please note that you may have to make changes to the path, if your installation directory is not the same as the above.