Connection Timeout when connecting with Friends

So my friends and I got the game today as it was on sale on Steam, downloaded it well and fine. Three of them manage to get into a party together but when I try to join I seem to be stuck loading in the joining moment until I time out.

The issue is also present when trying to que for games on my own, I seem to connect to games for a brief moment and then it tries to find other game lobbies.

I’ve read other forum posts and tried the various fixes except adding Port Forwarding due to not understanding how to do it correctly. Despite this though none of the fixes have worked after trying the game after attempting each fix

If anybody can help at all it would be greatly appreciated as the extend of the game right now is playing with three AI companions after waiting a while

Stubborn Connection Timeout errors are very often localised to the router or ISP.

To help isolate the issue, try connecting your PC to a mobile data connection to see if the error persists. However, I appreciate this isn’t always an option.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

Why not join the Fatshark Discord https://discord.gg/K6gyMpu