Connection timeout / connection error ps4

Please include as much information as possible in the description of your issue and include any crash reports produced (if applicable).

If you have already submitted your issue via the Fatshark Support Portal, please avoid double-posting here. You Support Portal query will be answered within 24 hours, Monday to Friday.

Got this game a couple of weeks ago along with my friends , worked out just fine , we connected to each others lobbies and played without issues.

The suddenly as of last week we started having issues connecting to one another. Me and my wife can connect to the same lobby cause we’re on the same network , our friends on the other hand cannot connect to us nor can we connect to them. The same error occurs each time “connection timeout / connection error” and when they try to connect I get a little message saying “xyz joining the game” 2 mins later “xyz left the game”

We play on ps4

Hi @Reaper

I’d recommend running through the solutions in this article:

Let me know how you get on!

I checked that last week and it’s correctly adjusted. We also hav NAT 2. My Friends however have a local internet provider that are set automatically to NAT 3.

They aren’t really used to adjust computer and network configuration. We’ll see if they manage and if that fixes the problem.

So my friend connect his LAN cable directly into the fiber box instead of the router and that solved the problem for a while , but once we left the lobby after finishing level we were back to square one.

Ah right! :frowning: hmm, is your friend able to adjust their network configuration and run through the other possible solutions?

He will try to reset his router and enable upnp to see if that solves it. However his brother who lives in the house next to him and have the same internet provider also plugged his cable to his fiber box and straight in to the ps4 and it did not work at all, he got error straight away.

This problem that we have. Is it included in the issue you’re currently investigating as mentioned on the top of the page?

Okay! Let me know how they get on.

If these solutions don’t resolve the issue, it is possible it could be related to the general connectivity problems introduced with the 3.4 update - which we’re actively investigating and working to improve.

My friend enabled upnp as of yesterday and nothing changed. I think the patch are messing things up since voice chat works perfectly and playing together 2 weeks ago worked perfectly without issues.

Ah, darn. :frowning:

Disregard my last comment, as I realize we’re talking console here! (d’oh), so the 3.4 update is unlikely to have a relation to this.

Could you please PM me with your PSN name (and that of your friend), and I can query this with our console developers and get back to you.

We who encounter problems are

Rimforsareaper ← me
Thebeforenooner ← friend
Johannaolsson ← my wife
19tyr92 ← friend’s brother

Thanks Reaper, I’ll pass this to our Console Devs, in case they can see anything on our end or offer any further suggestions. I’ll get back to you when I hear something back.

@Reaper, if you haven’t already, it may also be worth contacting your ISP and explaining the situation to them, in case the issue is something they can assist with. You can quote our PS4 server address: https://60F3.playfabapi.com

Today me and my companions played battlefield to see if we could connect to each others party , and there were no problem at all. With that said I don’t think it has to do with our internet connection.

I have also encountered other players attempting to join quick games that I am already in just to see them “leave” the game. The same error we encounter when trying to join one another . Seems like more people are having this issues as well

Hello?

Apologies for the slow reply @Reaper!

If possible, could you please try hooking your console up to a mobile data connection, to see if the issue persists? This can help to isolate the issue. I understand this is not always doable though.

We use 4G network as we live on the country side

So you’re using a mobile 4G data connection, with no access to a standard internet connection, is that right?

Additionally, your companions (other than your wife) are using a standard connection?

We haven’t patched on the PS4 in a while, so I’m inclined to believe this is more of a localised routing incompatibility which may ultimately solve itself.

Otherwise, I’d rather be honest with you in that we may not be able to identify this from our end, especially as we’ve made no recent changes to explain it. :disappointed: Console connectivity issues are especially hard to diagnose due to the lack of logging (compared to PC).

Should you wish to opt for a refund, you can explain your issue to PlayStation Support and they should be happy to process that for you. If you have any problems with it, let us know and we can intervene.

Correct, my friends got fiber and we got a 4G modem connected to an antenna , getting approximately 60 mib/s. I do not want any kind of refund , I like the game :slight_smile:

Well at least you know of our issue and can look into it since it happened so suddenly after working flawless for a week !

I see! Are you able to contact your 4G provider, explaining your issue? It may be something they can solve from their end.

Sure I can give it a go

Why not join the Fatshark Discord https://discord.gg/K6gyMpu