Can't launch modded realm even without any mods - Win 7

Hi! So far I have tried this:

  1. Successfully verified integrity of game files.
  2. Disabled all mods.
  3. user_settings.config successfully checked for not to be “Read-only”
  4. Set launcher to run as an administrator.

The official realm works normally, but when I select the modded realm and press “Play” the launcher disappears and nothing happens. No processes in Task Manager.
I tried beta launcher and temporary launcher.
With beta game can be launched, I can see ads, then black screen and game closed.
With temporary launcher game somehow worked last week, but now it does not launch like without any beta launchers.

I found advice from people who had the same problem in Win 10 and when they started the game on DirectX 12 the game started working. This leads me to the problem that there will be somewhere in DirectX.
I opened vermintide2_launcher.log and found many lines like:

05:36:25.217 [Launcher] [Launcher] [Main Window] [Check Exe] Looking for executable: D:\Steam\steamapps\common\Warhammer Vermintide 2\binaries\vermintide2_dx12.exe
05:36:25.217 [Launcher] [Launcher] [Main Window] [Check Exe] Executable missing

Of course, the game can’t find the vermintide2_dx12.exe file in this location, because it’s actually in D: \ Steam \ steamapps \ common \ Warhammer Vermintide 2 \ binaries_dx12

And why does the game even look for a DirectX 12 launcher when I don’t have DirectX 12? I think that’s the problem. Can you fix it? I would really like to play with mods that for some reason are still not approved …

1 Like

Don’t place too much emphasis on Executable missing, you’ll see that even in “normal” logs. :slight_smile:

Is a console log produced after (unsuccessfully) attempting to launch the ‘Modded’ realm?

Please upload it here if so.

I do not know where I should look for a console log, but there is
crash_dump-2021-03-10-19.22.14-(session not set).dmp
after unsuccessful attempt to Modded realm.
Here it is: crash_dump-2021-03-10-19.22.14-(session not set).dmp (134.7 KB)

Apologies, you should have a console log directory here:

  1. Press the Windows key + R
  2. Enter %appdata% within the search input and select ‘OK’
  3. Navigate to AppData\Roaming\Fatshark\Vermintide 2\console_logs

Ok, so without beta launcher is nothing created.
With beta launcher is crated this:
crash_dump-2021-03-11-15.56.47-83ef2ae4-3549-4f8a-9f56-1a3c2d655161.dmp (487.2 KB)
console-2021-03-11-15.56.47-83ef2ae4-3549-4f8a-9f56-1a3c2d655161.log (73.4 KB)
After I downloaded temporary launcher it works again like last week and this was created:
console-2021-03-11-16.27.21-fdc5c56a-4b52-4f4c-a5a9-652058dfe948.log (101.1 KB)
But I think that it will not work tomorrow again. I will let you know.

On a kind of unrelated note, I tried launching the game with the beta launcher and it just crashes.

Here are the logs :
console-2021-03-11-16.47.28-74c180e5-28fd-4028-8840-dbf76f6bfa81.log (168.2 KB)
console-2021-03-11-16.48.34-7ca44412-bf17-4101-b796-cb455bad1d07.log (167.7 KB)

And the crash dumps :
crash_dump-2021-03-11-16.47.28-74c180e5-28fd-4028-8840-dbf76f6bfa81.dmp (726.5 KB)
crash_dump-2021-03-11-16.48.34-7ca44412-bf17-4101-b796-cb455bad1d07.dmp (720.1 KB)

Another oddity : downloading the beta launcher was a very small and fast update, going back to “normal” launcher is a 9GB update :astonished:

Seems like it still works now with the temporary launcher. So maybe it was just something strange. But other 2 launchers still do not work with modded realm.

1 Like

It’s not ideal that you can’t launch using the “normal” launcher. :frowning:

If you haven’t already, you may need to repair your .NET Framework: [PC] How to Resolve Most Launcher Issues – Fatshark

1 Like

Yes, I did it before. I had 4.6.2 and I downgraded to this 4.5.2, but nothing changes…

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

Why not join the Fatshark Discord https://discord.gg/K6gyMpu