Bugged challenges

Recently I’ve tried completing 3 separate challenges and not had them complete.

Unfriendly fire - Attempted this in weaves, had the warpfire thrower kill more than 10 enemies and the challenge did not complete. No challenge broadcast and it was not completed in the book after completing the weave.

Unsteady aim - Had an Ungor archer kill a Minotaur in weave 7. No challenge broadcast and it was not completed in the book after completing the weave.

Evacuation bell (legend) - I started the timer when jumping down to the bell area. Destroyed the bell and got to the portal within 85 seconds. No broadcast message and the challenge was not completed in the book after the mission.

I’ve completed other challenges this patch, so it does not appear that all challenges are bugged, only these three.

Examples of challenges I’ve completed this patch: Unsafe work environment, Thar she blows

I am having the same issue with the Evacuation Bell challenge on legend - I have completed it within the time limit, and the challenge was not registered as completed, extremely frustrating since I am unable to get the frame for completing all helmgart mission challenges

Update: Unsteady aim is not bugged. The fire dot must have killed the Minotaur as the arrow hit. I got the challenge on weave 11 at the end event.

On Reddit someone advised that evacuation bell ticks over after the 85 seconds is up. So they recommended that if you get to the portal early, to wait until 85 seconds passes and then it should get the challenge.

Haven’t tried it yet but that might be the trick.

Unfriendly fire does seem to have an issue. I didn’t push or attack any enemies, but thought that maybe you need to push the warpfire thrower before it kills the enemies. Would be good to get some confirmation on this one.

Another update: Unfriendly fire definitely appears to be bugged. I pushed a warpfire thrower, then had it kill at least twenty enemies & the challenge did not complete.

The thing about Evacuation Bell is that it triggers soon after you drop down where the Rat Ogre spawns. When the Rat Ogre breaks the tomb gate, you drop down and move out of the cave-ish area, and that’s it. I know it used to be a bit buggy and I had to redo it a few times before it triggered for me. That was quite a few patches ago though.

It’s most definitely bugged then. I’ve attempted it five or six times & every time I’ve dropped down past the rat ogre within 85 seconds of starting the event

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

Why not join the Fatshark Discord https://discord.gg/K6gyMpu