Unfiendly fire challenge bugged

I have tried this challenge a couple of times now with no success. The description of the challenge says you need to “Have a warpfire thrower kill 10 enemies for you.” , but after getting him to kill well over 20 enemies the challenge still wasn’t completed.

I later tried not attacking and not pushing the enemies in any way, but after killing more then 10 of them the challenge still didn’t register.

No one else seems to have this problem as far as I know (only 2 of my friends who I play with), because I haven’t seen any online posts about it.

I mostly tried this in weaves btw, but also in base game.

If you have any tips I’m open to suggestions, but I believe the challenge is simply bugged.

I read somewhere that weaves challenges are not working.

Better try it in normal games.

hello , i think i have same issue with you , pretty sure bugged
i tried on hunger dark on recruit , i killed the bots with respawnable barrels , i were GK and just held shield ,then i let the fire rat followed me nearly half map ,it’s pushing the cart with me just like my pet , it’s killed everything for me, but i still don’t get the challenge

1 Like

I tried it today on recruit Halescourge with no success. I was plaing handmaiden and killed the botss on the boat with a tome. The warpfire killed well over 20 enemies, but the challenge still didn’t complete. I will send a video of it when I attemp it next time.

Maybe you need to do it on legend or cata?

I don’t think it matters, because the description doesn’t mention anything about difficulty.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

Why not join the Fatshark Discord https://discord.gg/K6gyMpu