Unfriendly fire challenge still bugged

I posted a bug report here half a year ago about this challenge being bugged and have seen another 2 reports from other people about this issue, but the challenge still isn’t fixed !

I can name more than 5 people from the top of my head who can’t complete this challenge, so this is definitely not only my problem. This challenge is IMPOSSIBLE to complete and has been for, as far as I know, about a year now.

I’ve tried completing it in weaves, normal Helmgard games on Against the Grain and Halescourge, on recruit, veteran and champion. I’ve tried to NOT damage and push enemies in any way, but even though the warpfire is the only one hurting them, the challenge still won’t complete. I’ve attemped it on the official realm of course.

There is simply nothing you can do to complete this right now and that really bothers me, because this is one of the few challenges I’m still missing.

You can watch this video for evidence (I attemped it on champ. against the grain with HM) : https://youtu.be/1vBLEclg3TQ

I really hope that this challenge will finally be acknowleged by the devs and fixed. If I can be helpful in any way, I will be glab.
Thank you.

3 Likes

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

Why not join the Fatshark Discord https://discord.gg/K6gyMpu