Black screen on character select

Issue Description:
I cannot open the app, blackscreen before selecting champion. if I can it’s impossible to join any game. it’s possible to join on another computer connected to network,
Tried reinstall vermintide, anticheat from support link + reinstall dependencies(.NET, drivers, C++). File integrity ok.
No crashing error, just Infinite loading.

Upload Console Log:
console-2023-05-22-20.33.08-1d47c525-f370-4584-928e-5193c7d6d775.log (467.3 KB)


Player ID:

Approx. Time of Issue & Timezone:
Any time
Reproduction Rate:
Constant (100%)

Upload user_settings.config:
user_settings.config (6.8 KB)

Hi @lacosmok,

Sorry to hear this.

I know you’ve mentioned reinstalling Vermintide already, but could you please try performing a clean reinstallation by also removing your AppData directory. You can find how to do this, here:

Unfortunately I’ve already done it before, but I don’t mind doing it again. Will keep you updated.

Ah okay! Have you made any recent changes or updates to your PC?

It may also be worth trying a Selective Startup, which can help diagnose whether a background application is resulting in your issue. This can be performed by:

  1. Press the Windows key
  2. Type ‘msconfig’ and select ‘System Configuration’
  3. On the ‘General’ tab, select ‘Selective Startup’
  4. Deselect ‘Load startup Items’
  5. Reboot your PC

If the issue no longer occurs after having performed the Selective Startup, try re-introducing your programs one-by-one to determine which is the culprit.

That’s a nice approach, didn’t thought of that, but still… 10 min waiting, and can’t select a hero. console log below…
console-2023-05-23-10.40.35-748e52d7-8eb7-404e-b36f-9048d62e44d8.log (100.4 KB)

Hmm, another shot in the dark, but can you load in correctly in Modded realm? (chosen from the launcher options)

As EAC only applies to Official realm, this can help in identifying if the issue is EAC-related in some way.

If so, I recommend to next try adding Firewall and Anti-Virus exceptions for both Vermintide 2 and Easy Anti-Cheat:

You’ll want to ensure you have the following exceptions in place:

  • vermintide2.exe in \Program Files (x86)\Steam\steamapps\common\Warhammer Vermintide 2\binaries
  • EasyAntiCheat.exe in \Program Files (x86)\EasyAntiCheat

Another thought, are you using a VPN or any mods?

If so, can you please try disabling these and check if there’s any change?

No VPN, disabled firewall, reset network card settings. Never used any mods.

Gotcha. There are unusual references in your log to Easy Anti-Cheat, Razer Chroma and Twitch - so I’m suspecting the issue may be EAC-related.

As above, can you please check Modded realm and see if that works?

After that, I recommend to try disabling any Razer software to see if there’s any change.

hmm… that’s interesting, when I try to open modded version, the window is not visible… Steam shows Vermiontide running, but I cannot see it. No console log either.
Just to be sure I tried the Easy Anti-Cheat reinstall, and it didn’t helped.
About Razer Chroma, that’s just keyboard, I have no Razer software either, and tried to reinstall drivers, and it didn’t helped.
Most recent consol log(From non-modded version):
console-2023-05-23-15.18.40-6c40dfc9-a1bb-4cd3-a8b3-dea257d09d3c.log (102.1 KB)

Hm I’m scratching my head a bit with this one! :frowning:

If possible, can you temporarily hook your PC up to a mobile data connection and see if the issue persists?

If you can load in and select a character with the mobile connection, then this can point towards a network/connectivity issue.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.