[XB1] - Vermintide 2 - Update 1 - Sonnstill Arrives!

When the people of the Empire come together to celebrate the King of Gods Taal and his spouse Rya they do it on the longest day of the year - Sonnstill (the day when the sun stands still in the skies). It’s a celebration of the good forces of life, of fertility and the power of the nature. What better way to celebrate than to bless all owners of Warhammer: Vermintide 2 on Xbox One with the Sonnstill Celebrations update.

We’ve given the keep a lush update with more greenery as well as a brighter appearance and added a double XP buff to all of you playing Vermintide 2 during the festivities. Oh, and don’t forget to finish the Sonnstill quests before the event ends in order to receive a unique portrait frame to flaunt even as the celebrations are over. The Double XP and Event Quests will go live on Friday, August 3rd.

Together with this event, we are also patching a lot of important fixes such as proper UI scaling and all keep decorations for the Premium Edition owners. All Game Pass players can still obtain this extra content through the Premium Edition Add-on.

We hope to see you all take this perfect opportunity to gather in the keep with drinks and songs to Taal’s honour - before charging into gruesome battle once again, of course. The Sonnstill Celebrations update runs from August 1st and ends on August 8th.

FEATURES:

  • Added UI scaling option
  • Added Sonnstill timed event (new keep decorations and event specific quests)

FIXES:

  • Performed memory optimization
  • Fixed an issue with players not getting the DLC content
  • Fixed a game flow issue when transitioning to another players game via invite
  • Fixed the motion blur option
  • Fix for some specials not playing any sound when close to player
  • Fix for clients getting an error message when hot-joining players from the initial start-up screen
  • Fixed softlock issue which could occur for players when one player got a pop-up while in loading screen
  • Fixed a transition issue which could occur when joining a player while in suspended mode
  • Fixed a crash that could occur when saving settings
  • Fixed a crash that could occur upon entering Bridge of Shadows after signing out from a profile
  • Fixed a crash that could occur when finishing installing DLC
  • Fixed a crash that could occur when accepting a game invite whilst in suspended mode
  • Fixed an issue where button callouts would be carried over to the main menu by selecting X and Y buttons at same time
  • Removed the pre-order button
  • Fixed an issue where the gamertag would scroll when having only one friend in the friends list
  • Fixed a case of Bardin’s Veteran Ranger career skill Disengage not working correctly
  • Fixed an issue where Sienna’s headpiece would be visible in first person when having her Vermintide 1 skin equipped
  • Fixed an issue where the player could activate the lifting platform on Skittergate while a client player was joining and a bot player was in hanging state
  • Fixed an issue with doors being open on final boss fight on Skittergate
  • Fixed a spot where enemies could not reach the player on Skittergate
  • Fixed culling issues and holes in the environment on Empire in Flames
  • Fixed an issue with the stairs disappearing at the Righteous Stand end event
  • Fixed a rock clipping issue on Righteous Stand
  • Fixed a spot where bots could get stuck on Fort Brachsenbrücke
  • Fixed several culling and pick-up issues on Festering Ground
  • Adjusted a respawn spot near the second tome on Festering Ground
  • Ratling Gunners can no longer shoot through a specific unit on Fort Brachsenbrücke
  • Fixed an issue where the cannonball could be thrown through the ground at specific location on Fort Brachsenbrücke
  • Fixed several issues where player would get downed instantly instead of hanging onto ledge on Fort Brachsenbrücke
  • Enemies can now walk where lifting platform used to be on Convocation of Decay
  • Fixed the sorcerers on Convocation of Decay so that they now are always visible
  • Fixed an issue with end event globe on Convocation of Decay not spawning
  • Fixed some holes and several culling issues in Convocation of Decay
  • Fixed several culling issues on Convocation of Decay
  • Adjusted the Bridge of Shadows so that it is now aligned to the ground on Convocation of Decay
  • Fixed a blocker issue on Convocation of Decay which could occur if the player got a boss after jumping down into the hole to the Old City Cesspit
  • Fixed an issue where players would respawn after the end event on The Screaming Bell
  • Fixed several culling issues on The Screaming Bell
  • Fixed a spot where bots could get stuck on The Screaming Bell
  • Fixed a spot where enemies could not reach player on Into the Nest
  • Fixed a spot where bots could get stuck on Empire in Flames
  • Fixed a spot where enemies could not reach player on Empire in Flames
  • Fixed several culling issues on Empire in Flames
  • Fixed several spots where bots could get stuck on The War Camp
  • Fixed an issue where player could get stuck between a rock and wooden spikes on The War Camp
  • Fixed a hole in geometry towards Bridge of Shadows on The War Camp
  • Fixed an issue where ammo crate would spawn inside a wood crate on The War Camp
  • Fixed so that a fire torch and tree no longer float in mid-air on The War Camp
  • Fixed an issue where Burblespue Halescourge could push players up on the roof during the end event on Halescourge
  • Fixed several culling and clipping issues on Halescourge
  • Fixed several spots where bots could get stuck or fail to rescue players on Halescourge
  • Fixed a spot where enemies could not reach players on Halescourge
  • Fixed an issue where bots could teleport past the end event on Halescourge
  • Fixed ledge and pick-up issues on Athel Yenlui
  • Fixed issues where items on Against the Grain would float in mid-air
  • Fixed pathing issues on multiple levels

TWEAKS

  • Tweaked the position of the ammo box above the water wheel on level Into the Nest
  • Enemies no longer float in mid-air when using climb ledges on The War Camp
  • Tweaked the DLC uninstall information
  • Tweaked the controller disconnection timer from 10 to 30 seconds
  • Tweaked the starting location on Halescourge to make it brighter
1 Like

#wewantcontent

3 Likes

Was the Achievements not unlocking issue for ‘Cage Breaker’ and ‘Feed Me Sinner’ included in this patch ?

Now game keeps crashing randomly middle of game. Happen now 4 times in different maps. Game just close it self. Something wrong on patch?

Damn, for a second I was excited that there’s a new PC content patch. Oh well. :frowning:

2 Likes

ye yeah I’m having the same issue on the Xbox One is well

No fix for Bardin getting stuck at the top of ladders? We had this issue since Vermintide 1…

So 3 weeks and no patch. Now there’s an event with double XP and a portrait frame I’ll miss out on because I’m flying out for 2 weeks tomorrow morning. Great.

Oh and to top it off all of my 9 friends online can’t finish a single run without crashing. So there’s that. Real umgak work guys. Seriously.

Since the update I can’t even connect to the game anymore. Sits on the press A to play screen.

This post is 5 hours old, but I still don’t see an event quest in the Okri’s challenges book. Is it just me?

Game Crashes with the new patch at loading maps. Happens never before the patch to me.
Game is now unplayable to me.

2 Likes

Event quests and double xp start on Friday.

1 Like

Not sure about quickplay but have been playing solo bots runs all day and not had the first issue.

Same as above, after patching, game continuously crashes when loading a level. Be it solo with bots or quick play, and even hosting, once the level is loading it hard crashes to dashboard. This happens on all characters, maps, and modes when online. Any update or acknowledgement to the issue would be lovely.

1 Like

We’re investigating the hard crashes on level loading and suspect it could be a missmatch in game versions. Let us know if it continues at the same rate now the patch has had time to propagate to more players.

So far, happened once today.

Update:
No more crashes now played 3hours yesterday everything went nice and the game looks much smoother now.

On 2 Achievements that were not unlocking ‘Feed me Sinner’ and ’ Cage Breaker’, we managed to unlock ‘Feed Me Sinner’ guess the Patch made it worked. But ‘Cage Breaker’ we have tried it twice 46 sec and 53 sec but its still bugged

Classes used HandMaiden, Slayer, Zealot and FootKnight
Process:
On First attempt, HM opened the first cage, running through opening next 4 cages inside the Barn and Slayer opens the 2 cages after climbing up the ladder and next Kruber openes the bottom cages in the Barn and last 2 cages opened by Slayer under 46Sec

Second Attempt, we started the timer from the tower right after killing the Chaos Warrior. HM Dashes down the tower opening the First cage and then next four cages, following up Slayer opened the 2 cages climbing up the ladder and Kruber pushing through the barn opened the bottom cages inside the barn and HM dashed on last 2 cages on top finishing the run in 53 sec.

An update on this would be much appreciated!

Same here, %100 of the time at the first initial load of any quest. Rebooted Xbox, but to no avail. Game freezes, sound skips and buzzes, then closes. Arrgh

I know its a bit long process but Uninstall and re-install your game it worked for me, not once after that.

1 Like

Can’t see any event atm. Should it be active now? Keep decorations x2 Xp and such?

Day 3 and still %100 crashing exactly at loading the quest. Any more info Fatshark_Hedge? I’m missing the slaughter…
I’m not sure that it has anything to do with other player’s versions, if that’s what you meant in your post. I tried it offline and it crashed in the same manner in the same spot, right at the end of the load. Froze, sound studders, and then game closes.
Redownloading is the last resort for me. Not only does it take days, I’d say bye-bye to another large chunk of my monthly download quota.

I tried to clear the cache by using all methods listed to clear the cache (xBox One S), but didn’t work. I tried a brand new XBox profile that didn’t have a saved game, nope. I noticed that I had 2 premium content that wasn’t installed so I installed those, but that didn’t help either. Same hanging in the same spots.

I am running my XBox in 720p mode for some other reason, but the game worked fine prior to the update in this mode.(switch systems to 1080p, nope) I also uninstalled the old Beta version at the same time to make some room (wasn’t critically low on space, so there shouldn’t be an issue caused by lack of space), could there be anything in the old beta it needed?

Sigh, after waiting a few days, I’m biting the bullet and re-downloading the 32GB and re-installing. Hope this works.

Update, re-downloaded the whole thing and yep, that fixed it. Thanks Chester

Why not join the Fatshark Discord https://discord.gg/K6gyMpu