Unmapped Keybindings cause instant crash upon opening keybinding settings

Issue Description:
I went into the keybinding settings to remap some keys. I unmapped my special melee key (with the intent to remap it to something else) but I exited the settings before I remapped it. I attempted to go back into the keybinding settings to map the special melee key and the game crashed instantly. Now, every time I attempt to open the keybinding settings the game crashes. I have tried to access the keybinding settings from the character select screen and from inside the ship, but both cause a crash. I am now unable to use the special melee ability and it’s game breaking for me.

Crash Report (If Applicable):
No crash report.

Error Displayed (If Applicable):
No error displayed, crash to desktop.

Steps to Reproduce:

  1. Navigate to keybinding settings.
  2. Unmap special melee key.
  3. Exit keybinding settings.
  4. Navigate back to keybinding settings.
  5. Crash.


Player ID:

Approx. Time of Issue & Timezone:
11/23/2022 approx. 6pm PST

Reproduction Rate:

Upload Console Log:
console-2022-11-30-18.18.20-4da6152b-1dec-4d0f-b215-8c7e21bae480.log (89.1 KB)

Upload darktide_launcher.log:
darktide_launcher.log (713.1 KB)

Thank you for your report, we’ll check it out.

Here are the things I have tried on my end, to no avail:

  • Reinstalled.
  • Set worker threads to =< 6.
  • Tried in game after logging in; tried in main menu.
  • Disabled sync and deleted Darktide folder in APPDATA to regenerate it.
  • Updated drivers and such.
  • Tried it in Windowed, Borderless, FullScreen

I severely hope for a fix soon - it’s game breaking :frowning: and I know I’m not the only one with this issue unfortunately.