Unable to Launch - Launcher Process Only

Hi,

Game is installed on an external SSD, when I run the game the launcher process starts (see screenshot) but the game never launches.

I’ve restarted my laptop and verified the game files in steam.

You could try disabling the launcher.

Right click on vermintide 2 in your steam library, hit properties, go to the ‘betas’ tab and select the ‘bypass launcher’ beta. The bad thing is you can’t change any setting that is only changeable from the launcher (like directx version to use, for example), but it might let you into the game, at least until a FS dev can give you a proper solution/answer.

3 Likes

To identify if the issue is in displaying the launcher, you can try launching the game in “launcher bypass” mode, you can do that by right-clicking the game in your Steam library and selecting ‘Properties’, ‘Betas’ and then opting into the Bypass Launcher beta from the dropdown.

image

This at least will narrow it down. For most issues in having the launcher ‘launch’, this note from Julia should help:

download the appropriate version of the .NET Framework from the Microsoft website linked below. The installer should then prompt you with an option to repair your installation.

Be sure to restart your PC afterwards!

Windows 10 : NET Framework 4.7: https://www.microsoft.com/net/download/dotnet-framework-runtime/net47

Windows 7 : .NET Framework 4.5.2: https://www.microsoft.com/net/download/dotnet-framework-runtime/net452

3 Likes

Hi Hedge,

So disabling the launcher worked and I can get into the game now.

I looked at installing the NET Framework. but the installer throws up the following:

“.NET Framework 4.7 or a later update is already installed on this computer.”

So it won’t install.

Happy to provide logs or info to help you troubleshoot this.

1 Like

If you find .Net Framework in your installed apps in windows, do you get a Modify > Repair option?

Oddly enough it doesn’t appear in my list of apps, and I didn’t see a repair option in the installer

Unfortunately .NET is not visible in the installed apps.
@Grimseal: Do you have the recent Windows Updates installed?
There is however a repair tool available by Microsoft, I don’t know if it’s any good tho:
https://support.microsoft.com/en-us/help/2698555/microsoft-net-framework-repair-tool-is-available

I am a bit suspicious about the “external SSD” (over USB, right?) thing… Definetly seems a bit unconventional…
Was this working before? Is it possible that your Anti-Virus might scan through this removeable device? I definetly had oddish behaviours with Anti-Virus scanning through USB-drives…

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.