Unable to join or have others join my session


I am unable to find any join any online session and no others can join me if I host a session. to begin with when I installed the game 4 days ago I could join games and people could join me easily, but the next day when I loaded up the game I couldn’t join any games and when I hosted, players couldn’t join my session but would be stuck in the loading process never fully joining until they eventually were kicked because they are unable to reach me. when they join a portrait would appear like when normally someone joins your session, apart from the portrait would just buffer until they left.

I don’t know what to do, I have tried reinstalling the game, verifying it, changing the download region, clearing my download cache, messing with the network setting but nothing has worked, and there is only so much of bots killing themselves on harder difficulties that you can take. I’m really getting back into this game but not being able to play with other players is making it seem like there is no point playing at all. please help before I have to give up on this game completely

Hello, I’ve responded to your query via the Support Portal.

For anybody else experiencing this issue, please see our article on the Connection Timeout error here.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.