Unable to buy aquilas

Issue Type (Required):

Purchases & Aquilas

Issue Description (Required):

I’ve been trying for roughly an hour to purchase 2400 aquilas, however, each time I click “authorize” on steam to buy them with the funds in my wallet, the transaction does not properly process. The game will show me as having received the aquilas, but when I then check my steam wallet the money is still there. I am able to repeat this and stack up high quantities of fake aquilas. The moment I actually try to buy something with them, the game says “purchase failed” and shows my actual amount of aquilas.

[PC] Do You Use Mods? (Optional):

No, I don’t use mods

Reproduction Rate (Required):

Constant (100%)

Platform (Required):

Steam (PC)

Player ID (Optional):

Upload Supporting Evidence (Optional):

I mean… looks like it failed and then successfully processed… 5 times? Because it looks like you HAD 100 aquilas now you’ve got 12100 based on the last screenshot and your description of showing false readouts until the “purchase failed” message with the actual amount of Aquilas in your account.

If it’s still only 100 in the account and you’ve not actually been charged, I’d say the game’s accidentally failed in your favor and done you a service (Fatshark doesn’t need to be rewarded for their reskinning of “premium” cosmetics right this moment).

It doesn’t “fail successfully”, that’s the problem. The screenshots uploaded in the wrong order. The moment I try to purchase anything with the aquilas, the amount displayed reverts back to the actual amount: 100.

Your personal opinion on the MTX is not helpful nor was it asked for.

UPDATE: It just randomly worked when I tried it today. Can close this thread I guess lol.

Thank you for the update, I’m pleased to hear it miraculously resolved itself! :slight_smile: Closing as requested.