The occasional very long wait times for a new weapon in expeditions

On rare occasion a weapon shrine will take a much longer time to give players their weapon and the time in-between players can’t use their weapon or ability. It usually takes only a second or two but sometimes it can take much longer for a player to be able to play the game again, I’ve had a friend without a weapon for nearly or more than 2 whole minutes.

This specific video example had two of us without a weapon for a little over a minute. (723.1 KB)

Pressing 2 times the “X” button works for me. Then the issue is solved.

That’s most likely placebo :sweat_smile:

Had this problem couple of times, and as i said for me it worked

Yeah this killed console CW for me. Once had the group wipe after grabbing weapons during a minute long time out where no one could defend against the horde that started while we were grabbing weapons specifically in a minute of downtime to avoid this nonsense.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.