Server list not populating

Hello, I seem to be having an issue all of a sudden with the server list. I have over 700 hours on this game with no issues up until now. When i log in on the official realm and go to search for a server to play on , no servers show up . from near to far to world nothing is populating. This problem started 2 days ago, I have tried restarting my PC / Restarting Steam / to no avail

Can someone tell me if there is some problem currently with the servers (3/29/19) or is there something I need to do to fix this issue??

Thank you

1 Like

I don’t have any help to add, just a +1 over here from me. Nothing showing up anywhere

Try that

1 Like

No this is not going to work as I have tried it.

Weird… I just got this bug this morning. I closed the game, then right clicked on steam and “exit steam”, then relaunched steam and the game worked for me. I’ve got the bug a few times the past 2 weeks. But that’s always worked. What happens if you go into the lobby browser and change the “Show Lobbies” to “all”?


Does this populate the server list now?

I guess just upload a console log and you DXDIAG.

Had this problem come up to me just now. Just restart Steam, worked for me.

I’m also having this issue. Tried restarting steam, clearing the download cache, verifying game file integrity, and restarting my PC with no effect. I really don’t want to have to reinstall…

Edit: Showing ‘all’ games does populate the list. Difficulties on the unjoinable list all show as “-” without the “” and scrolling down quickly gives a wierd noise, like the normal scroll noise repeating over itself. Does that help anyone?

Edit #2: I was getting a bunch of errors about mods, so I removed them all. No change.

Perhaps copy your V2 files to another location. Yea I know it’s 75GB lol. Then uninstall it, and drop the files back. Then reinstall, it’s worth a shot before a full redownload if your Internet is bad.

I’ll give that a shot and report back. Cheers.

That helped, thanks alot!

Well, I have tried everything - restarting steam, restarting clearing the steam download cache, Still no results - this is what I am seeing, I dont understand why this is happening all of a sudden out of the blue. 3 days have gone by with no results. I am starting to wonder if reinstalling the game will do anything? just dont want any damage to my character profiles

I have tried everything to fix this issue. Short of reinstalling the game. I have reset my pc / reset steam / cleared downloads / Verified steam cache / Turned off all of my mods, nothing is helping this issue. I am still seeing this

This most likely won’t not fix it^

Nor does any of the other fixes floating around.

Nothing at all game servers are totally unresponsive on all lobbies - search distance - world

A new patch was just released. Is it working now?

Yes, but there is an option for “Show lobbies”, by default it’s on “Joinable”. If you set it to “all”. Do you see a list of servers? Or is it still empty. If it’s still empty, your not even connecting to the steam server list then I guess. Try changing your download region. For example, if your in Sweden, try changing to Denmark.

We’re looking in to this. We’re not sure why this is suddenly such a prominent issue. Before anything, and this is aimed at everybody here experiencing this issue, please ensure you’ve tried the solutions below:

  • Restarting Steam
  • Restarting your PC
  • Clearing Steam’s download cache
  • Changing Steam’s download region
  • Ensuring the appropriate Firewall/Anti-Virus exceptions are in place for both Vermintide 2 and our anti-cheat service, Easy Anti-Cheat

And, of course, please ensure you have the latest updates installed as 1.6.1 was released earlier.

Please keep me posted.

1 Like

I tried that and it didn’t work.

1 Like

Thank you, It seems as of right now - 4/1/19 6:50pm eastern time after I installed the most recent patch released today the issue is fixed. I shall inform if anything changes. Thank you.

Mine fixed on its own before the update. All good now I checked it today 2nd of April 2019 at 1:30 pm AEST.


I’m also working again, whatever you did, it worked. Thanks!

Why not join the Fatshark Discord