Mods not loading into the game after enabling them from launcher

Context: The game and mods were working just fine recently after setting up my new laptop with my previous SSD. Then I decided to do a system restore back to the time when I was setting up my laptop to fix a problem, created more problems generally speaking and reverted back to the original restore point. That made me had to reinstall Vermintide 2 again and the base game works. However, despite enabling the mods from the launcher, they don’t load into the game. I’ve done it many times after verifying files, making sure my appdata user_logs were not on Read Only and resubscribing mods from the Workshop.

Does anyone know what else I can do to fix this so that I can play Vermintide 2 again with mods? Thanks.

Are they in the correct order?

I do not follow. What do you mean by that question?

When you open the mod list from the launcher, certain mods need to be loaded first, which means they have the at the top of the list. Normally if they aren’t in their proper order, there will be a red text saying it’s not loaded or something like that.
Also generally the mods that need to be loaded first are things like libraries and general mods that you need to run most other mods, if that makes sense.

I did have mods organized in the proper order like Vermintide Framework mod at the top of the list. And still, the game doesn’t even give me mod options.

have you ever closed steam since you did all that?

I know i had the same issue once but once I restarted steam it fixed because it finally started downloading all the workshop mod’s

If you mean ending task via task manager, yes. I’ve restarted steam that way multiple times and it still hasn’t helped with my mod issue.

I have no idea what could of caused it. Hope someone can solve it for you.

I think I’m just going to reinstall Vermintide 2 because I’m not sure what else to do for the moment. Thanks to everyone for trying so far. Will update later.

1 Like

If you haven’t tried it, you may want to try unsubacribing and then resubscribing to the mods.

I reinstalled VT2 and that didn’t solve the problem. And resubscribing was one of the first things I did. I might take this to the Steam Discussion board for further assistance.

Is your config file set to read-only for some reason? This blocks mods from loading that weren’t marked in the launcher while the file was writable.

  1. Open Windows File Explorer and type %appdata% in the address bar.
  2. Open the Fatshark folder.
  3. Open the Vermintide 2 folder.
  4. Select the user_settings file and double check if it is set to read-only.

This is what I got for the user_settings file. I double clicked on user_settings.config and I opened it up with Visual Studios 2019. And I currently have the “Read Only” box unchecked. Still, I can’t launch the mods with this.

Just to be sure. Is any file or folder set to read only?

Also i’m gonna tag a cm @FatsharkJulia to help you out.

The only file with “Read Only” checked is the one I circled. I haven’t applied changes to it though. Everything else is unchecked in that box.

Did you try unchecking that file?
Or is it not good to do that?

Somehow, they all have the “Read Only” box unchecked. I tried again and I still couldn’t load my mods in.

I fixed the problem. Turns out I just had to delete the Vermintide 2 Workshop folder in my steam path. Thanks for all the help regardless!

2 Likes
Why not join the Fatshark Discord https://discord.gg/K6gyMpu