KNOWN ISSUE: Armory Exchange Flickering/Refreshing/Appearing Blank, Unable to Purchase, Or Displaying Only 2 Items

In cases where users are unable to purchase from the Armory Exchange due to it constantly refreshing, you may need to reset your PC’s date and time to Automatic.


Existing reports may be merged here, to help us keep track of the issues being reported.


I noticed after having launched the game multiple times and interacting with the weapon-shop that it is permanently bugged and flickers the image of one or two guns that I cannot buy or inspect, I also can’t scroll through the shop as that is also broken.

On your computer’s clock, right click and select “Adjust Date/Time.”
Enable “Set time automatically”

This seems to be a known issue, my buddy had the same problem and I found another thread that suggested to do that and it worked for him.

Edit: Here is link to other thread: Armoury Exchange is stuck in constant refresh - #3

1 Like

I have the same issue. Seems like it is almost scrolling through the weapons at hyper-speed. I was able to buy a couple of things despite the flickering during one shopping experience, but the second time I tried to buy something it did not let me. The “purchase” button stayed muted (I could afford it).

The shop is permanently stuck on refreshing at 0 seconds and is flickering and scrolling, rendering it unusable.

In the FAQ it is mentioned this is due to an improperly configured system clock. Set your system clock correctly, ideally using the Microsoft NTP servers.

I cant purchase anything from the armory. It constantly refreshes and scrolls me to the top which makes it impossible to purchase anything.

1 Like

This was also present in the closed beta, hope a fix is found soon

I am also having this problem, and hope this gets fixed soon-ish

Hey, found a fix, if you are on PC, go to your time settings and sync your computer time with the internet time, was an immediate fix for me, idk why lol.

I am also having this issue. I’ve tried uninstalling and reinstalling it didn’t help either

Sync your computer time with your internet time in your clock settings.
Was an immediate fix for me!

1 Like

It work. Thanks so much

1 Like

We kindly ask that you complete the questions below. With this information, we can investigate your issue properly.

Issue Description:

Crash Report (If Applicable):
[Please see instructions on how to provide a crash report in the pinned Topic]
Armoury Exchange is stuck in constant refresh and can’t buy any weapons
Error Displayed (If Applicable):

Steps to Reproduce:
[Please add the steps that can help our QA department in reproducing the issue. For example:]

  1. Play Chasm Logistratum as Ogryn (Skullbreaker)
  2. Attempt to pick up the second Grimoire
  3. Crash
    Just anytime I walk up to it, try to buy a weapon with my level 3 psyker
    Mission Name (If Applicable):

[Steam/Microsoft Store]
Player ID:
[Steam ID/Steam Profile URL/GamerTag]

Approx. Time of Issue & Timezone:
11/17/2022 4:00Pm est
Reproduction Rate:
Once - Rare (<10%) - Unusual (<25%) - Common (<50%) - Often (<75%) - Constant (100%)
Upload Supporting Evidence:
[Screenshots, recordings, links to Twitch VODs, etc.]

Upload Console Log:

  1. Press the Windows key + R
  2. Enter %appdata% within the search input and select ‘OK’
  3. Navigate to AppData\Roaming\Fatshark\Darktide\console_logs
  4. Locate the console log that corresponds with the session in which the issue occurred, by looking at the timestamps in the log names
  5. Upload here

Upload user_settings.config:

  1. Press the Windows key + R
  2. Enter %appdata% within the search input and select ‘OK’
  3. Navigate to AppData\Roaming\Fatshark\Darktide
  4. Locate the user_settings.config in this directory
  5. Upload here
    user_settings.config (3.2 KB)

i have the same problem

fixed it, check your computer time

Glad you were able to resolve this @Red

Does the same solution also fix this issue for you @Kreigesman?

checking now

yep setting my clock to automatic fixed the issue