Kantrael Infantry Lasgun on Zealot Preacher does not fire while aiming down sights

Issue Description:

Kantrael Infantry Lasgun on Zealot Preacher does not fire while aiming down sights. I aim, press left click, and nothing happens. I can shoot from the hip without problems, I can aim down sights normally, but I can’t shoot while aiming down sights.

This issue only occurs with Kantrael Infantry Lasguns. I’ve tried 3 different Kantrael Infantry Lasguns and it happens with all 3. All other weapons can aim down sights and fire without issue.

The issue only occurs using Mouse and Keyboard and only with the default keybindings. If I use a controller, I can shoot while aiming down sights. If I change the primary and secondary weapon keys, I can shoot while aiming down sights.

I’ve tried using a Steelseries Rival 310 mouse and a Steelseries Rival 3 mouse and both have the same problem.

Please let me know if I can share any more info to help diagnose this issue. Thank you!

Steps to Reproduce:

  1. Equip Kantrael Infantry Lasgun, any variety, as Zealot Preacher
  2. Enter any mission or the Meat Grinder
  3. Hold Mouse 2 to aim down sights
  4. Press Mouse 1 to fire, but the gun does not shoot

Mission Name (If Applicable):

Issue occurs in all missions and Meat Grinder


Player ID:
Bald Bull

Approx. Time of Issue & Timezone:
[12/24/2022, 01:00PM] [CST]

Reproduction Rate:

Constant (100%)

Upload Supporting Evidence:
I could post a picture of the gun not shooting but that doesn’t feel like it would help. Let me know if there’s anything specific you’d like to see and I’ll get you what I can.

Upload Console Log:

console-2022-12-24-18.54.45-faf62eaa-8923-4797-9bc7-eb2b471c16a8.log (86.0 KB)

Upload darktide_launcher.log:

darktide_launcher.log (446.6 KB)

Thank you for your report! Any chance you could show me a picture of the weapon card of the lasgun you’re trying this with? Just in case some blessing or some stat or SOMETHING is messing with it. I doubt it’s related but it’s just such a weird bug that I figure any info might help.

Sure! Below are the three guns I’ve tried and all have the same issue.


Thank you for looking into this!

I did find a temporary workaround by binding Primary Action to the N key in-game and rebinding my left mouse button to hit N, which lets me shoot while aiming down sights, but it’s a bit inconvenient to switch mouse profiles every time I want to play.

1 Like