How do we remove mods with no workshop page?

Currently on my mod list from the launcher, if I click on the Source Viewmodel mod, it crashes the launcher. In looking at the workshop, it appears the mod is no longer available / visible / whatever. How do I remove this mod from my list?


I’ve got a couple of these as well and would like to show the answer. Mine even show REMOVED FROM WORKSHOP in the launcher

There’s two way I found to deal with these.

First, a bit annoying but direct, go to workshop, seek that “Remove all mods” and take mods you want back again, most of the parameters you set in game will have been saved, so there’s no real loss

Second, go to your Steam/SteamApps/workshop/content, find your VT2 folder (mine is 552500, don’t know if that’s a global name), and browse through the mods folder till you can find the one containing Source Viewmodel. And delete it :stuck_out_tongue:


I think there was a way to remove those by going to the workshop and to “subscribed mods”. There they should show from what I know.


Alistair is correct, I had a similar issue with removing the Waypoint Mod.
If you browse to the Workshop and look for the word “Browse” with a drop down arrow which will include “Subscribed Items”
Selecting that will allow you to see all your subscribed mods including those that may no longer be listed on the workshop page.


Lots of superb recommendations in here. Let us know if this is still an issue for you OP. :slight_smile:

1 Like

I tried doing this because it sounded like it had the most straight-forward approach. It appears to have worked perfectly, and many thanks for the tip.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.