Heavy swords are unusable after 1.2.11

I am not sure what happened to the animation but it now has about 0.1 s delays between light attacks that make absolutely harder to deal with hordes.

Heavy swords have been really effective against hordes, their light and heavy attacks have high cleaves and only spamming light attacks could easily hold and wipe out them. However, after the recent updates, the heavy swords have very awkward delays between attacks that allow hordes to hit the players which have never happened before the update.

Is this an intended change? I could not find any changes regarding Turtolsky heavy swords in the previous patch notes. These awkward delays only happen to heavy swords. I tried other zealot melee weapons but could not find such issues.


I thought something felt off. Not a frequent vet player though.

I almost exclusively run heavy sword (VI and XI) on my zealot and I haven’t noticed any sort of additional delay, nor have I had any problem sweeping through auric damnation runs.

1 Like

Heavy swords are zealot exclusive.


It’s still good used to be my easymode for chill t5/auric
mostly run knife small chainsword and catachan beacuse I accidently rolled a highstat and it’s an underdog that got slept on and got insanly good after update.
but heavy sword is still good with headtaker/deathblow insted of good ol rampage

Edit: If you not having it in your build try it maybe it take care of that delay

Untill you are not a bot, heh.

1 Like

as a Mk IX heavy sword enthusiast, I must disagree that it was nerfed, if anything it feels stronger now.

Yep, typo/sleepy. I frequently play vet, but tried my zealot after the latest patch.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.