Gsync not working properly?

Hey guys,
is anyone else having weird issue with gsync and micro stutters? I have 120hz gsync screen but no matter what I do if I dont turn on / force vsync (and cap my framerate to 60fps as a result) the game isnt playing smooth, there is micro tearing and micro stutter all over the place. Its somewhat worse with gamepad but its still there with mouse as well.

Its not that big of a deal, 60fps is still ok, im just wonderring if its just me.

Similar thing here. The latest update smoothed things out a lot for me, but it’s still level-dependant. I think it likely it’s more closely related to CPU optimization.

1 Like

yeah i noticed some threads on my 5800x3d get maxed out which seems crazy as its still one of the most powerful gaming cpu out there

I can confirm seeing very similar issues and instability in the frame rate and micro stutter might be the correct wording, for their is a noticeable hick-up in the smoothness.

After reading a post about G-sync turned on resulted in more frequently crashing, I’ve also turned off G-Sync through the Nvidia game profile settings for Darktide, for I also had random crashes I could not explain. On top of stability, their is a rather noticeable difference what I perceive as much smoother motion and less hick-ups, but also input lag feels much more responsive. Kind of weird, for that’s what G-Sync supposed to help out with in the first place.

My FPS is hugging v-sync limit at 98fps a lot more consistently now.
If I’ve an higher FPS and less FPS dips, I don’t know for I’m not seeing the hick-ups in smoothness anymore, so I’m going to say it’s overall better to have G-Sync off, at least for me at the moment.

1 Like

Strangely game only crashed on me once since I got it on launch date so i just turn on vsymc and let the gsync on in the nvidia control panel. every once in a while of theres an update ill try vsync off, hopefully they will fix it at some point.

Yeah I dont think the micro stutters are related to gsync, cuz if i turn that off its the same. If you map your farme times to a graph you can see that they spike all the time. Like Im talking 50ms, while the frames dont dip at all. Its just here and there is one frame that something is happening in the engine that makes everything wait. If youre used to playing high refeshrate games, and the mouseinput you get from that, it feels like crap.

He is also mentioning tearing tho. For me gsync works fine. No tearing whatsoever.

thing is when vsync is on its all smooth, but locked to 60fps. with vsync off even of i push 100fps its not smooth, but its hard to describe really. its like skipping frames or something.