Getting error when trying to launch the game

Whenever I launch the game, I get this error:
image
After clicking Ok, I get this message:
image
I tried to do everything according to the link that show how to get around the problem: https://support.fatshark.se/hc/en-us/articles/360007853137--PC-How-to-Resolve-Most-Easy-Anti-Cheat-Errors#Untrusted%20System%20File:%20C:\Windows\System32\wldap32.dll, but to no avail.
When running the Windows System File Checker, I got this message instead:
Windows Resource Protection found corrupt files but was unable to fix some of them
I tried to reinstall but there is no change to this error.
Please help me solve this problem.
Thank you.

Would you be able to email a copy of the wldap32.dll to community@fatshark.se please, so I can then pass it on to Easy Anti-Cheat for analysis?

Is there an instruction for me to do this or I just need to copy-paste the wldap32.dll to community@fatshark.se?
Edit: I can’t attach it to email because it doesn’t allow me to and says "Blocked for security reasons! "

If you haven’t already, please create a copy of the DLL, and place it somewhere memorable such as your desktop. Then, right-click it and select ‘Send to’ → ‘Compressed (zipped) folder’. Are you able to upload it as an email attachment then, with it being zipped?

It is still blocked for security reason in gmail.
edit: please tell me how to solve this solution.

@mook31213

If you are using Gmail, it won’t let you send that file, because of its binary nature. If you try to send executables or certain links, Gmail will block it because it’s a common way to spread viruses.

Even if you change the name and extension of the file, you will still have that problem, because Gmail analyses the file itself.

But you should be able to upload that file into a Google Drive PRIVATE folder and then share that folder (or file) with Fatshark by sending them the link with reading permission. But it is important that you delete that folder/file after they tell you they received it, just in case somebody else tries to access it (although improbable, because they would need to hack your Gmail or Fatsharks, e-mail, it can still happen in the long term)

It would be superb if you could upload it to Google Drive as mentioned by Rodo above, and then supply us with a link to it.

You could, alternatively, contact us via https://support.fatshark.se and attempt to upload it there.

I have upload it to the google drive and share the link to community@fatshark.se.

I have received the link and sent a request for access. :slight_smile:

Hello Julia, sorry for the wait. This is the link of google drive share:
Edit: I hope I am doing this right.
Additional edit: I have allowed access to the file.

Sadly, it looks like the attachment is a Shortcut as opposed to the wldap32.dll itself, meaning I cannot access it. Please create a copy of the DLL (as opposed to a Shortcut) and paste it to your desktop, and then use the right-click it and select ‘Send to’ → ‘Compressed (zipped) folder’ option. :slight_smile:

Please sent a request for access. I have shared you the copy link just now.

Received! Thank you, I have passed this on to Easy Anti-Cheat.

Hello, has the issue been resolved yet?

Unfortunately I’ve yet to receive a response from Easy Anti-Cheat, but I’ll let you know as soon as I do.

Hey Mook. This is the response received from Easy Anti-Cheat:

seems wldap32.dll validated is failed, running sfc /scannow command with admin privilege, might be can help to solve the problem.

[Sfc command]
Use the System File Checker tool to repair missing or corrupted system files

But it’s my understanding you’ve already done this, which then produces an error.

With this error you may need to explore other solutions as it seems an underlying issue is at play. Have a look at: https://www.thewindowsclub.com/windows-resource-protection-found-corrupt-files

Of course, I’m happy to contact Steam and request that they issue you a refund for Vermintide 2 should you rather take that option.

Is there any solutions for me to fix the game?
edit: it says that I need to replace the corrupted system file with a known good copy of the file. But I don’t have a copy of the file wldap32.dll. Can you ask them if they have the good copy and if they can show me how to replace it?

Unfortunately neither us nor Easy Anti-Cheat can supply copies of the DLL.

Do you have another PC in your household, or somebody you can trust to send you a clean version of the DLL?

It’s my understanding the DLL is stored in this directory:

C:\Windows\SysWOW64

Yes, I am able to find it in that directory. What should I do next?

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.