Game won't launch

Just purchased Vermintide 2 on Steam. Excited to start playing and then I immediately run into this error.
Please Help!

MainWindow invocation error: System.NullReferenceException: Object reference not set to an instance of an object.
at Launcher.GameSettingsHolder.<.ctor>b__89_6()
at Launcher.GameSettingsHolder.parseSetting[T](String key, Func`2 parse_func, Boolean force_default)
at Launcher.GameSettingsHolder.LoadSettings(Boolean force_default)
at Launcher.GameSettingsHolder…ctor(SysInfo si)
at Launcher.MainWindow…ctor()

Update:
Restarted pc. Verified files through steam. Tried clicking the game .exe directly just flashes a black box and no launch. Launching through steam gets me the same error response.

This link might help
https://support.fatshark.se/hc/en-us/sections/360002936593-Vermintide-2-Common-Questions-Problems-Solutions

In Steam library, properties for Vermintide 2, betas tab, if you switch to temporary_launcher_workaround and then launch the game, picking the “bypass launcher” option, does it still crash?

What if you remove the FatShark folder from your Roaming folder in User/AppData?

Followed instructions. Now I get splash screen, then a black box in the upper left had corner and a brief popup that said Vermintide II. Then nothing, no error message.

What are your PCs specifications @Sulcath?

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

Why not join the Fatshark Discord https://discord.gg/K6gyMpu