Game instantly crashes by using xbox 360 gamepad controller

Issue Summary:
Ever since the patch, using an xbox 360 gamepad controller causes the game to freeze and crash upon pressing the blue X button.


Steps to Reproduce:

  1. Plug in xbox 360 controller via USB, and press the X button anywhere in Taal’s Keep, while facing an object to interact with or otherwise.
  2. Also occurs when attempting to adjust settings, the X button will freeze and kill the game no matter the context.

Reproduction Rate (Choose One):
Once
Rare (< 10%)
Unusual (< 25%)
Common (< 50%)
Often (< 75%)
Constant (100%)
Constant 100%, every single time I’ve pressed the button.

Additional Information:
I noticed it first occurring when I logged into the game after the patch downloaded. Using a controller, I ran to Okri’s challenges book, and hit X to access, which immediately froze my game. I thought it a fluke at first, and rebooted the game to the exact same outcome. Then I restarted my computer, and logged back in after, and instead of trying to access the challenges book, I tried to start a mission. This interaction also involves the X button on the xbox controller, and immediately froze and crashed my game. Another time I booted it up, and simply tried to talk to Lohner, which also caused it to crash. I gave up at this point and assumed it was just something associated with the other bugs, and took a break.

Later, my friend wanted to play, so I logged on and warned him I couldn’t seem to access anything, which still seemed to be true after a quick test. Because of the updates, all my graphics in Taal’s keep were far crisper, however as a result my framerate had decreased, and so I went into my settings to adjust my graphics, and hit the X button to reset to defaults. This was where I realized it wasn’t a problem of interacting with the various objects in the keep, but a bug related to the X button on the controller, as my game froze and crashed yet again. To test, once more I logged in and this time didn’t touch the controller, but ran up to Okri’s book and pressed E on the keyboard to access, to which I experienced no problems whatsoever. Further, me and my friend then started a mission, to which we did to completion, with no bugs occurring. To conclude that the X button was the culprit, I finally looked at no objects in the keep, just off into space after the mission, and pressed the X button, which immediately froze the game. This leaves no doubt in my mind the bug is exclusively related to the X button, as I was able to move about, switch weapons with the Y button, crouch with B, and jump with A, but pressing the X button at all resulted in an immediate crash.

I suppose I could simply leave the controller behind, but I learned the game on the controller, played ~300 hours using the controller, and am now unable to use the controller, so I hope you can fix whatever may be causing this!

[Attach a Screenshot and/or Video Evidence]
(Screenshots and/or video evidence (if applicable) can be particularly helpful. To upload, click the ‘Upload’ icon within the post controls.)


ON PC:

[Attach Your DxDiag]
(Press ‘START’ and enter ‘DxDiag’. Select the DxDiag app and allow it to load. Once loaded, click the 'Save All Information…" button and save to a location of your choosing. To upload, click the ‘Upload’ icon within the post controls.)
DxDiag.txt (103.0 KB)

[Attach Your Session Console Log]
(Navigate to C:\Users\YOURNAME\AppData\Roaming\Fatshark\Vermintide 2\console_logs and locate the log that corresponds with the particular session in which your issue occurred. To upload, click the ‘Upload’ icon within the post controls.)

This should be solved now.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

Why not join the Fatshark Discord https://discord.gg/K6gyMpu