Game crash on launch with empty error message

My game crashes immediately after i press ‘play’ in the launcher.Error message is empty,no GUID, GUID:
Log File:
Info Type:

Could not fetch or upload crash info

I’m pretty sure it’s Easyanticheat issue or something, because i have tried modded realm, works just fine.

To this point i have tried:
-Updating Windows and all Drivers to latest version
-Verifying Files and re-download EasyAntiCheat
-Re-Install EasyAntiCheat
-Checked the Registry if there is any trace of CheatEngine (nothing)
-Disabled anything that is not a Windows related app
-Deleted EAC directly from instal folder, checked integrity, reinstalled again
-Cheked other games with EAC, like, Squad,
(I thought it’s conflicting with other EAC versions, so i deleted everything, every game except Vermintide and all the appdata. Nothing changed.)
-Tried switching from dx11 to dx12 and back
-Repairing .NET, installing again
-Flushed DNS (just in case)

Log says something about not being able to fetch .exe file
01:44:53.166 [Launcher] [Main Window] [Check Exe] Executable missing
01:44:53.166 [Launcher] [Main Window] [Check Exe] Exe name: stingray_win64_dev_x64_dx12.exe

01:44:53.166 [Launcher] [Main Window] [Check Exe] Looking for executable: C:\Program Files (x86)\Steam\steamapps\common\Warhammer Vermintide 2\binaries\plugins\stingray_win64_dev_x64_dx12.exe
01:44:53.166 [Launcher] [Main Window] [Check Exe] Executable missing
vermintide2_launcher.log (13.2 KB)

I’m confident this is related to Easy Anti-Cheat, can we confirm the appropriate Firewall exceptions are in place for Easy Anti-Cheat?

I just disabled firewall to chek it, same thing.
And i couldn’t find EAC in Firewall exceptions, there is no EAC client to add there
Am i doing something really wrong here?

Strange, please PM me with your Easy Anti-Cheat ‘loader’ log (located using the instructions below) and I’ll pop a message over to them to ask what’s up:

  1. Press the Windows key + R
  2. Enter %appdata% within the search input and select ‘OK’
  3. Navigate to AppData\Roaming\EasyAntiCheat\226

Nothing in there, just tried to install it all over and now it shows this:
copy file failed with 32,

that means another program in the system is holding a lock to the EAC service executable that is copied into the system32 folder.

Im going to search it now, sorry for bothering you.

I fixed it, if anyone else having same problem:

So i deleted manually everything that has EasyAnticheat in the title

Steam\steamapps\common\Warhammer Vermintide 2\launcher

Than clicked repair in EAC installation\verifyed integrity.
And funny thing, nothing that i deleted reappeared

Appreciate the update! Nice work, I’ll bear this in mind for anybody else that has this issue. :slight_smile:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

Why not join the Fatshark Discord https://discord.gg/K6gyMpu