G-Sync seem not to work

I am using VM2 in exclusive fullscreen mode with no v-sync set and no frame limit set but I get vertical tearing. Other games work fine. What’s wrong? Does VM2 not support G-Sync in exclusice fullscreen?
At the moment I am using vsync setting on to correct the tearing.

Is G-Sync appropriately enabled in the NVIDIA Control Panel? Please see below:


1 Like

Sorry I need to take this topic up again.
I have now set the NVIDIA settings accordingly. My monitor is set to 120HZ, VGA is a RTX3080.
But when I have vsync disabled in VM2 and no cap set, I still get vertical tearing.
Lets say it works fine for one time, than an other time it is not working with no settings changed!
It works when I join a game. Then when the games has ended back in the fortress after the loading screen, tearing appears again.
What I have found out so far:
My LG monitor has a standard g-sync setting and an advanced setting.
Not documented what each mode actually does.
When I have tearing in VM2 and when switching from one the g-sync mode to the other, indepently from the option chosen^^, G-Sync works fine, no teating!
But it is not working permanently. As workaround I switch between the monitors g-sync modes.
I also see that when full screen (exclusive) is set in VM2, actually borderless windowed is active after switching monitors g-sync mode.
So I expect G-Sync ist not working properly in VM2 exclusive full screen mode?

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.